Page 1 of 1

Steam Games Won't Load

Posted: Thu Mar 13, 2014 0:49
by DeftPon3
Hey everyone! I would like to start by saying I absolutely love Sabayon Linux. I just started using it and it has become my favorite Linux distribution. I however have run into an issue with playing Steam games. I download the games just fine (Portal 2 and Metro Last Light), but when I click "PLAY" my screen goes black for a split second (as if the game were about to appear) but then I just go back to my desktop. I figure it may be a graphics driver issue. I have not installed any of my own graphics drivers, I am using whatever Sabayon came with when I installed it. I have a ATI Mobility Radeon HD 5650. Any help would be much appreciated :)

Re: Steam Games Won't Load

Posted: Thu Mar 13, 2014 16:05
by Stupot
What's the output of:

Code: Select all

# eselect opengl list


That will be needed for anybody who hopes to help.

Re: Steam Games Won't Load

Posted: Thu Mar 13, 2014 17:27
by DeftPon3
Thanks for your reply! :) I got this output.
Available OpenGL implementations:
[1] xorg-x11 *
[2] ati
[3] nvidia

Re: Steam Games Won't Load

Posted: Thu Mar 13, 2014 19:45
by Stupot
You'll probably want to use ati proprietary drivers for running games.

From gentoo's wiki (all of these work for Sabayon):

This will modify an existing xorg.conf to use the fglrx driver with a single screen:

Code: Select all

root # aticonfig --initial --input=/etc/X11/xorg.conf


For dual-head configuration use this instead (where the second screen is [left|right|above|below]):

Code: Select all

root # aticonfig --initial=dual-head --input=/etc/X11/xorg.conf --screen-layout=[left|right|above|below]


Set the OpenGL driver to use fglrx:

Code: Select all

root # eselect opengl set ati


Then reboot.

If for some reason that leave you in a horrible state and you can't do anything, this will revert that change:

Code: Select all

root # mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak
root # eselect opengl set xorg-x11l

then reboot.

Re: Steam Games Won't Load

Posted: Thu Mar 13, 2014 21:16
by DeftPon3
When I enter "aticonfig --initial --input=/etc/X11/xorg.conf" into terminal (as su), I get "bash: aticonfig: command not found". I am not the most experienced Linux user, so I might be doing something wrong. Any idea as to what I am doing wrong? :)

Re: Steam Games Won't Load

Posted: Thu Mar 13, 2014 23:00
by Stupot
Hmm, maybe you need to set the opengl first (my bad)..

Code: Select all

root # eselect opengl set ati


If that doesn't work, you can follow the guide in the wiki, although truthfully it goes way above and beyond what should need to be done to make the switch:

https://wiki.sabayon.org/index.php?titl ... e_to_FGLRX

Re: Steam Games Won't Load

Posted: Fri Mar 14, 2014 2:51
by DeftPon3
Yeah :/ I get this output:
"!!! Error: The ati OpenGL implementation doesn't seem to provide
!!! Error: libGL.so file. This might be an effect of breakage introduced
!!! Error: by a prioprietary driver installer. Please re-merge the package
!!! Error: providing your OpenGL implementation.
!!! Error: Selected OpenGL implementation incomplete.
exiting".

Do you think that perhaps downloading and installing the driver from ATI would make it work? Or do you think that would break my system?

Re: Steam Games Won't Load

Posted: Fri Mar 14, 2014 15:16
by Stupot
Reinstall the ati-drivers through entropy (the Sabayon package manager). Instructions on how to do so were in the wiki I linked you, specifically:

Code: Select all

root # equo install x11-drivers/ati-drivers amdcccle

Re: Steam Games Won't Load

Posted: Fri Mar 14, 2014 22:05
by joost
This might be an effect of breakage introduced by a prioprietary driver installer.

NEVER install the ATI/AMD drivers directly from their website, it breaks everything.

Re: Steam Games Won't Load

Posted: Sun Mar 16, 2014 0:09
by DeftPon3
Okay! I'll give it a shot. Thank you very much for your help! :)