Oolite - Object Oriented Elite [Solved]

A place where Linux Gamers can share their experience and help each other with Linux Games, native or emulated ;)

Moderator: Moderators

Oolite - Object Oriented Elite [Solved]

Postby nobicycle » Thu Jul 04, 2013 2:46

Elite was an 80's space trading game, an excellent combination of strategy and shoot-em-up.
OOlite is an award winning more modern version, under active development. http://oolite.org/

Unfortunately I cannot get it to run.

It is not present in entropy and emerge produces the following:

Compiling file src/Core/Universe.m ...
Linking objc_program oolite ...
/usr/lib/gcc/x86_64-pc-linux-gnu/4.7.3/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find libobjc.so.3

libobjc is a dependency of the following:

Version 1.77 (latest) of oolite is in the "rion" overlay.
eix --deps libobjc
* games-action/oolite [1]
Available versions: (~)1.77 **9999 {debug doc}
Homepage: http://oolite.org/
Description: Elite space trading & warfare remake

[U] gnustep-base/gnustep-make
Available versions: 2.6.2 (~)2.6.2-r2 (~)2.6.3 (~)2.6.4 {debug doc libobjc2 native-exceptions}
Installed versions: 2.6.2-r2(10:39:42 PM 12/11/2012)(-debug -doc -libobjc2 -native-exceptions)
Homepage: http://www.gnustep.org
Description: GNUstep Makefile Package

emerge gnustep-base/gnustep-make-2.6.4 produces
* Warning: changed libobjc.so version!!
* The libobjc.so version used for gnustep-make has changed
* (either by the libojbc2 use-flag or a GCC upgrade)
* You must rebuild all gnustep packages installed.

When I follow these instructions, I get
gnustep-updater -l

* Locating packages for an update
* Adding to list: sys-devel/base-gcc:4.6
* Adding to list: sys-devel/base-gcc:4.7
* Adding to list: virtual/gnustep-back:0
* Adding to list: gnustep-base/gnustep-base:0
* Adding to list: gnustep-base/gnustep-gui:0
* Adding to list: gnustep-base/gnustep-back-cairo:0
* emerge -vD1 sys-devel/base-gcc:4.6 sys-devel/base-gcc:4.7 virtual/gnustep-back:0 gnustep-base/gnustep-base:0 gnustep-base/gnustep-gui:0 gnustep-base/gnustep-back-cairo:0

* IMPORTANT: 7 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "sys-devel/base-gcc:4.6".
* gnustep-updater is stopping here:
* Fix the problem and start gnustep-updater again.

So I am stuck at
there are no ebuilds to satisfy "sys-devel/base-gcc:4.6

Any ideas?

Best wishes
Last edited by nobicycle on Mon Oct 21, 2013 8:05, edited 1 time in total.
Simple Hen
Posts: 77
Joined: Fri Nov 20, 2009 13:55

Re: Oolite - Object Oriented Elite

Postby nobicycle » Mon Oct 21, 2013 8:05

I dropped the idea of using an ebuild and used the install file taken from the the game website, but it generated permission errors.
Solution, temporarily remount /tmp
Code: Select all
sudo mount /tmp -o remount,rw,exec,sui
Simple Hen
Posts: 77
Joined: Fri Nov 20, 2009 13:55

Return to The Gamers Shed

Who is online

Users browsing this forum: No registered users and 1 guest