Page 1 of 1

nvidia and sauerbraten - some errors

Posted: Fri Nov 30, 2007 21:49
by rava
Hi, I'm just trying Sabayon 3.4f DVD.
It rocks, but also has some problems. I googled a bit but found nothing which solved it all so I post here.

My system: 3GB RAM, Athlon 64 X2 Dual Core Processor 4200+, NVidia GeForce 7600GS (256 MB RAM)

When booting, it gives an error:

Code: Select all

could not load /lib/modules/2.6.22-sabayon/video/nvidia.ko.

There is apparently a module for a 2.4 kernel (which should be named ".o"):

Code: Select all

sabayonx86 ~ # insmod /lib/nvidia/nvidia.o
insmod: error inserting '/lib/nvidia/nvidia.o': -1 Invalid module format
sabayonx86 ~ # insmod /lib/nvidia/nvidia.mod.o
insmod: error inserting '/lib/nvidia/nvidia.mod.o': -1 Unknown symbol in module
sabayonx86 ~ # file /lib/nvidia/nvidia.mod.o
/lib/nvidia/nvidia.mod.o: ELF 32-bit LSB relocatable, Intel 80386, version 1 (SYSV), not stripped
sabayonx86 ~ # file /lib/nvidia/nvidia.o
/lib/nvidia/nvidia.o: ELF 32-bit LSB relocatable, Intel 80386, version 1 (SYSV), not stripped

On another forum I found the hint to install the, but it won't work.
It says

Code: Select all

No matching precompiled kernel interface was found on the NVIDIA ftp site;
this means that the installer will need to compile a kernel interface for
your kernel.

[...  more "deprecated" errors ...]
   /tmp/selfgz16890/NVIDIA-Linux-x86-1.0-9626-pkg1/usr/src/nv/nv.c:1844: warning: 'deprecated_irq_flag' is deprecated (declared at include/linux/interrupt.h:66)
   /tmp/selfgz16890/NVIDIA-Linux-x86-1.0-9626-pkg1/usr/src/nv/nv.c:1845: warning: passing argument 2 of 'request_irq' from incompatible pointer type
   make[4]: *** [/tmp/selfgz16890/NVIDIA-Linux-x86-1.0-9626-pkg1/usr/src/nv/nv.o] Error 1
[_module_/tmp/selfgz16890/NVIDIA-Linux-x86-1.0-9626-pkg1/usr/src/nv] Error 2
   make[2]: *** [modules] Error 2
   nvidia.ko failed to build!
   make[1]: *** [module] Error 1
   make: *** [module] Error 2
-> Error.
ERROR: Unable to build the NVIDIA kernel module.

sauerbraten gives the error

Code: Select all

X Error of failed request:  BadLength (poly request too large or internal Xlib length error)
  Major opcode of failed request:  129 (GLX)
  Minor opcode of failed request:  1 (X_GLXRender)
  Serial number of failed request:  1067
  Current serial number in output stream:  1068

I suppose course there is no direct rendering: glxinfo says:

Code: Select all

direct rendering: No

I tried the following (taken from thread [stabalizing 3.4f (known Issues and Fixes) ])

Code: Select all

[email protected] /opt $ sudo emerge emul-linux-x86-xlibs && eselect opengl set xorg-x11 && eselect opengl set nvidia
Calculating dependencies /
!!! All ebuilds that could satisfy "emul-linux-x86-xlibs" have been masked.
!!! One of the following masked packages is required to complete your request:
- app-emulation/emul-linux-x86-xlibs-7.0-r8 (masked by: missing keyword)
- app-emulation/emul-linux-x86-xlibs-10.0 (masked by: missing keyword)

so "emerge emul-linux-x86-xlibs" failed (exit code 1)

Update 2
But that seems to work...

Code: Select all

sabayonx86 opt # emerge emul-linux-x86-xlibs

 {[.. failed like above ..]}

sabayonx86 opt # eselect opengl set xorg-x11 && eselect opengl set nvidia
Switching to xorg-x11 OpenGL interface... done
Switching to nvidia OpenGL interface... done
sabayonx86 opt # glxinfo
name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4

Now I try it with sauerbraten, hope it won't crash again :D

But one problem resists:
when I switch the keyboard with "sudo keyboard-setup de.nodeadkeys" to "de.nodeadkeys" the key between the left shift and the "y" key on the german qwertz keyboard is not accessed. That key holds the "greater than", "smaller than" and "pipe" symbol.

Re: nvidia and sauerbraten - some errors

Posted: Fri Nov 30, 2007 22:46
by rava
unfortunately now sauerbraten gives a strange error:

Code: Select all

[email protected] /tmp/NVIDIA $ sauerbraten_client-bin
init: sdl
init: enet
init: video: mode
init: video: misc
init: console
cannot find data files (you are running from the wrong folder, try .bat file in the main folder)


Re: nvidia and sauerbraten - some errors

Posted: Sun Dec 02, 2007 18:05
by rava
Is really Nobody here to give some kind of advice?
Unfortunately I cannot write Italian as I hardly speak any Italian at all but that should be no problem, I hope. I am not of English origin neither.

Re: nvidia and sauerbraten - some errors

Posted: Sat Jan 26, 2008 17:58
by the_darkside_986
The version of Sauerbraten shipped with Sabayon is way out of date (by at least two releases) anyway so you should download the latest release from

In the default installation from the website, the working directory is ./ or another words, wherever you unzip the Sauerbraten tar ball from. For example, mine is /home/myUserName/software/sauerbraten so i must cd to that directory and run ./sauerbraten_unix.

Re: nvidia and sauerbraten - some errors

Posted: Thu Feb 07, 2008 16:37
by paintball9
ive had that error before too, that sauerbraten error is made for the windows version, im not sure why its the same error on the linux one, anyways you could just reinstall the game and that should fix that problem, for some reason its looking in a different folder for the data files.