Page 1 of 1

Problems with wine

Posted: Sun Nov 11, 2007 20:41
by erus
I got everything working. For the most part, otherwise I wouldn't be here. My problem is that when I try and run my game that I installed (I bought this game legally, mind you) I get a "piracy protection" message. How can I turn that off so that I can just play my game?

Here is the process I have gone though so far:
emerged wine
configured wine
moved all my cd's files over to a local folder
installed the game under wine
everything launches just fine, i get the launch application, I click go, and It gives me above said piracy message.

Thanks pre-emptively for your help

Dave

Re: Problems with wine

Posted: Mon Nov 12, 2007 1:12
by Cohan
Unfortunately, some copy-protections malfunction with wine. First thing to try is to install the game directly from the CD and not copy the content to your harddrive first. Most copy protections won't allow installation from a *copy* you made to your harddrive.

Re: Problems with wine

Posted: Mon Nov 12, 2007 10:35
by linuxrocks
have you mounted the game cd's iso image and assined a wine drive link? this works for many games. it thinks the cd is in the drive.
you could also get a no/cd crack of the net to bypass this protection.

Re: Problems with wine

Posted: Mon Nov 12, 2007 11:13
by chsims1
You might also try the latest version of wine which has:
Wine 0.9.49 was released today, with the following main changes:

* Many copy protection fixes.
* GLSL is now the default for Direct3D.
* Lots of memory errors fixed thanks to Valgrind.
* Support for TOPMOST windows.
* Beginnings of an inetcomm dll implementation.
* Lots of bug fixes.

Re: Problems with wine

Posted: Sun Nov 18, 2007 23:12
by erus
Sorry it has taken me forever in a day to respond. I appreciate all the help and now finally have time to try out fixes.

Re: Problems with wine

Posted: Thu Nov 22, 2007 21:36
by erus
Okay, I have successfully installed the newest version of Wine. Everything to a point has gone smooth. Now there is a new problem. The Starforce copy protection granted my game access but wants me to reboot to continue the install. It wont move past that point. I even tried rebooting (You shouldn't ever have to in Linux except for the kernel, or so I have been told.)

Well, at least I have two $20 Frisbees.

Re: Problems with wine

Posted: Thu Nov 22, 2007 23:18
by dunsurfin
For the reboot, have a look here: http://wiki.jswindle.com/index.php/Wineboot

Re: Problems with wine

Posted: Thu Nov 22, 2007 23:29
by erus
Hi, thanks for the advice, I went to the link and tried both and they failed. The manual reboot failed because evidently I don't have WININIT.INI

Re: Problems with wine

Posted: Sun Nov 25, 2007 23:56
by Azerthoth
There are times when I have to use a trick to get beyond copy protection. It's not 100%, but it does clear things up once in awhile.

as root:
mount /dev/sr0 /mnt/cdrom

It seems that wine does not terribly like things being automounted in /media. Forcing it to /mnt/cdrom sometimes clears the issue for me.
Just an idea.