Page 1 of 1

vlc codec? [Risolto]

Posted: Thu Feb 28, 2019 8:54
by marcb
vlc mi da questo errore:

Code: Select all

Codec not supported:
VLC could not decode the format "h264" (H264 - MPEG-4 AVC (part 10))
Codec not supported:
VLC could not decode the format "mp4a" (MPEG AAC Audio)
posto che il file non è corrotto e si può vedere benissimo,
ho provato ad installare

Code: Select all

media-plugins/gst-plugins-meta-0.10-r11
ma senza successo
come posso risolvere? :mrgreen:

Re: vlc codec?

Posted: Thu Feb 28, 2019 11:21
by fiorello
Guardando la pagina VLC Features Formats il codec che da l'errore è:

"AAC mp4a faad (decode), faac (encoding) ISO/IEC MPEG"

In Entropy ci sono due plugins, uno sembra installato di default, prova a rimuoverlo e installare l'altro.

Code: Select all

╠      @@ Paquet: media-plugins/gst-plugins-faac-0.10.23-r1 branche: 5, [sabayonlinux.org] 
╠          Disponible:       version: 0.10.23-r1 ~ tag: NoTag ~ révision: 0
╠          Installé:         version: Pas installé ~ tag: n/a ~ révision: n/a
╠          entaille:         0.10
╠          Page d'accueil:   http://gstreamer.freedesktop.org/ 
╠          Description:      plugin for gstreamer 
╠          License:          [code]GPL-2
╠      @@ Paquet: media-plugins/gst-plugins-faac-1.14.3 branche: 5, [sabayonlinux.org] 
╠          Disponible:       version: 1.14.3 ~ tag: NoTag ~ révision: 0
╠          Installé:         version: 1.14.3 ~ tag: NoTag ~ révision: 0
╠          entaille:         1.0
╠          Page d'accueil:   https://gstreamer.freedesktop.org/ 
╠          Description:      AAC audio encoder plugin for GStreamer 
╠          License:          GPL-2
&&

Code: Select all

 @@ Paquet: media-plugins/gst-plugins-faad-0.10.23-r2 branche: 5, [sabayonlinux.org] 
╠          Disponible:       version: 0.10.23-r2 ~ tag: NoTag ~ révision: 0
╠          Installé:         version: Pas installé ~ tag: n/a ~ révision: n/a
╠          entaille:         0.10
╠          Page d'accueil:   http://gstreamer.freedesktop.org/ 
╠          Description:      plugin for gstreamer 
╠          License:          GPL-2
╠      @@ Paquet: media-plugins/gst-plugins-faad-1.14.3 branche: 5, [sabayonlinux.org] 
╠          Disponible:       version: 1.14.3 ~ tag: NoTag ~ révision: 0
╠          Installé:         version: 1.14.3 ~ tag: NoTag ~ révision: 0
╠          entaille:         1.0
╠          Page d'accueil:   https://gstreamer.freedesktop.org/ 
╠          Description:      AAC audio decoder plugin. 
╠          License:          GPL-2

Re: vlc codec?

Posted: Fri Mar 01, 2019 0:08
by marcb
dopo vari tentativi risolto reinstallando

Code: Select all

x11-libs/libvdpau-1.1.1
grazie a mpv che mi ha messo sulla buona strada:

Code: Select all

error while loading shared libraries: libvdpau.so.1: cannot open shared object file: No such file or directory