Octopress RubyGem [Risolto]

Tutto ciò che è pertinente a Sabayon Linux, indipendentemente dall'architettura e dall'ambiente grafico

Moderator: Moderators

Octopress RubyGem [Risolto]

Postby Vinc3nt » Wed Apr 30, 2014 17:11

Premetto che usando Jekyll tutto funziona perfettamente.

Ho installato Octopress seguendo la guida sul sito ufficiale ma quando lancio il comando (rake preview) per il localhost ho un white screen.

$ rake preview
Code: Select all
Starting to watch source with Jekyll and Compass. Starting Rack on port 4000
[2014-04-30 18:08:03] INFO  WEBrick 1.3.1
[2014-04-30 18:08:03] INFO  ruby 1.9.3 (2013-11-22) [x86_64-linux]
[2014-04-30 18:08:03] INFO  WEBrick::HTTPServer#start: pid=6819 port=4000
/home/vinc/.gem/ruby/1.9.1/gems/yajl-ruby-1.1.0/lib/yajl.rb:1:in `require': cannot load such file -- yajl/yajl (LoadError)
   from /home/vinc/.gem/ruby/1.9.1/gems/yajl-ruby-1.1.0/lib/yajl.rb:1:in `<top (required)>'
   from /home/vinc/.gem/ruby/1.9.1/gems/pygments.rb-0.3.4/lib/pygments/popen.rb:3:in `require'
   from /home/vinc/.gem/ruby/1.9.1/gems/pygments.rb-0.3.4/lib/pygments/popen.rb:3:in `<top (required)>'
   from /home/vinc/.gem/ruby/1.9.1/gems/pygments.rb-0.3.4/lib/pygments.rb:1:in `require'
   from /home/vinc/.gem/ruby/1.9.1/gems/pygments.rb-0.3.4/lib/pygments.rb:1:in `<top (required)>'
   from /home/vinc/.gem/ruby/1.9.1/gems/jekyll-0.12.0/lib/jekyll.rb:27:in `require'
   from /home/vinc/.gem/ruby/1.9.1/gems/jekyll-0.12.0/lib/jekyll.rb:27:in `<top (required)>'
   from /home/vinc/.gem/ruby/1.9.1/gems/jekyll-0.12.0/bin/jekyll:20:in `require'
   from /home/vinc/.gem/ruby/1.9.1/gems/jekyll-0.12.0/bin/jekyll:20:in `<top (required)>'
   from /home/vinc/.gem/ruby/1.9.1/bin/jekyll:23:in `load'
   from /home/vinc/.gem/ruby/1.9.1/bin/jekyll:23:in `<main>'
>>> Change detected at 18:08:04 to: screen.scss
identical public/stylesheets/screen.css

Dear developers making use of FSSM in your projects,
FSSM is essentially dead at this point. Further development will
be taking place in the new shared guard/listen project. Please
let us know if you need help transitioning! ^_^b
- Travis Tilley

>>> Compass is polling for changes. Press Ctrl-C to Stop.
127.0.0.1 - - [30/Apr/2014 18:08:18] "GET / HTTP/1.1" 404 - 0.0307


$ ruby --version
Code: Select all
ruby 1.9.3p484 (2013-11-22 revision 43786) [x86_64-linux]


$ gem environment
Code: Select all
RubyGems Environment:
  - RUBYGEMS VERSION: 2.0.14
  - RUBY VERSION: 1.9.3 (2013-11-22 patchlevel 484) [x86_64-linux]
  - INSTALLATION DIRECTORY: /home/vinc/.gem/ruby/1.9.1
  - RUBY EXECUTABLE: /usr/bin/ruby19
  - EXECUTABLE DIRECTORY: /home/vinc/.gem/ruby/1.9.1/bin
  - RUBYGEMS PLATFORMS:
    - ruby
    - x86_64-linux
  - GEM PATHS:
     - /home/vinc/.gem/ruby/1.9.1
     - /usr/local/lib64/ruby/gems/1.9.1
     - /usr/lib64/ruby/gems/1.9.1
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :backtrace => false
     - :bulk_threshold => 1000
  - REMOTE SOURCES:
     - https://rubygems.org/


Help please... grazie
Last edited by Vinc3nt on Sat May 03, 2014 9:04, edited 1 time in total.
Vinc3nt
Baby Hen
 
Posts: 16
Joined: Mon Oct 14, 2013 12:56

Re: Octopress RubyGem

Postby Vinc3nt » Sat May 03, 2014 9:03

Aggiornato a ruby 2.1.0 e installato rubygems 2.2.2 ora tutto funziona (sarebbe stato meglio cambiare i GEM PATH ma ho lasciato tutto di default)
Vinc3nt
Baby Hen
 
Posts: 16
Joined: Mon Oct 14, 2013 12:56


Return to Sabayon Linux Discussioni Generali

Who is online

Users browsing this forum: No registered users and 1 guest

cron