Configurazione di rete sparita dopo aggiornamento

Tutto ciò che è pertinente a Sabayon Linux, indipendentemente dall'architettura e dall'ambiente grafico

Moderator: Moderators

Configurazione di rete sparita dopo aggiornamento

Postby marco.azzalini » Fri Mar 21, 2014 11:59

Ciao, ieri sera ho fatto fare l'aggiornamento dei 63 pacchetti che da qualche giorno Magneto voleva aggiornare e questa mattina, dopo il riavvio, ho scoperto che non mi andava più la rete... il pannellino per gestire le interfacce e le connessioni è desolatamente vuoto (sparita la mia eth0 e anche le connessioni VPN che avevo configurato). Perdipiù se provo ad aggiungere una scheda con Manage Connections, non posso perchè il tab Wired è disabilitato :-(
Per ora ho tamponato con:

/etc/init.d/net.eth0 start

ma la domanda é. CHE CAVOLO è successo ??? A qualcuno di voi è successa la stessa cosa?
C'è modo di recuperare la situazione precedente?

ciao e grazie
Marco
marco.azzalini
Baby Hen
 
Posts: 11
Joined: Wed Mar 06, 2013 11:09

Re: Configurazione di rete sparita dopo aggiornamento

Postby sabayonino » Fri Mar 21, 2014 12:40

ciao

quel comando è per OpenRc il quale se non lo hai mantenuto te manualmente è stato sostituito da systemd , per cui è irrilevante l'output che rilascia

credo tu possa trovare una soluzione qui , sembra un problema simile al tuo. ma dai una letta generale anche ai post precedenti prima di applicare comandi.

ciao

[edit] onestamente non capisco perchè ad alcuni si presentano questi problemi (spesso di rete , ma anche di login) con gli aggiornamenti.
ho il repo weekly e fino ad ora mai nessun problema (su portatile)... mah :?:
User avatar
sabayonino
Sagely Hen
 
Posts: 2537
Joined: Sun Sep 21, 2008 1:12
Location: Italy

Re: Configurazione di rete sparita dopo aggiornamento

Postby marco.azzalini » Mon Mar 24, 2014 9:47

Ciao, grazie mille per la risposta... in effetti il thread che mi hai segnalato descrive esattamente il mio problema solo che la cura non ha dato risultati apprezzabili :-( se faccio quella modifica non mi va in rete e provando a tirare su l'interfaccia a mano da un errore.
Poi riprovo con calma e provo a dare qualche info in più

per il momento grazie ancora

Marco
marco.azzalini
Baby Hen
 
Posts: 11
Joined: Wed Mar 06, 2013 11:09

Re: Configurazione di rete sparita dopo aggiornamento

Postby marco.azzalini » Mon Mar 24, 2014 10:04

RiCiao, mi correggo. Ho riapplicato la modifica e in effetti 'non fa danno' ma nemmeno aiuta :-(
Diciamo che devo sempre lanciare

'net.etho start'

e che il pannello di configurazione è completamente vuoto e con i pulsanti disabilitati. :-(
Ho provato a fermare e rilanciare NetworkManager da riga di comando ma senza risultati apprezzabili.

ciao e grazie
Marco
marco.azzalini
Baby Hen
 
Posts: 11
Joined: Wed Mar 06, 2013 11:09


Re: Configurazione di rete sparita dopo aggiornamento

Postby marco.azzalini » Mon Mar 24, 2014 10:40

Ciao, un restart da questo:

>systemctl restart NetworkManager
>Failed to get D-Bus connection: No connection to service manager.

Non so se anche questo sia un problema dovuto al 'weekly-update' o ci sia qualche altro problema sotto...

Comunque ho provato a fermarlo 'dolcemnet' con un SIGTERM e poi l'ho rilanciato, ma l'interfaccia viene su senza indirizzo.
Ho fatto stop e start della eth0 e alla fine si è presa un IP e sono tornato online.
Proverò a lavorare su questo nuovo problema, forse è l'origine del problema....

ciao
Marco
marco.azzalini
Baby Hen
 
Posts: 11
Joined: Wed Mar 06, 2013 11:09

Re: Configurazione di rete sparita dopo aggiornamento

Postby axelaxel6 » Tue Mar 25, 2014 23:36

secondo me c'è stato qualche casino con i servizi attivati, se sei passato a systemd verifica se è attivato il servizio dbus, con il comando
Code: Select all
systemctl
e hai l'elenco (è una pipe del risultato con 'less') dei servizi attivati se non c'è dbus va attivato con
Code: Select all
systemctl enable dbus
, solo che ho appena provato a dare il comando e mi dice:
Code: Select all
The unit files have no [Install] section. They are not meant to be enabled
using systemctl.
Possible reasons for having this kind of units are:
1) A unit may be statically enabled by being symlinked from another unit's
   .wants/ or .requires/ directory.
2) A unit's purpose may be to act as a helper for some other unit which has
   a requirement dependency on it.
3) A unit may be started when needed via activation (socket, path, timer,
   D-Bus, udev, scripted systemctl call, ...).

credo che hai un gran bel casino, bisognerà cercare dei link in qualche directory .wants o .requires in /etc/systemd o /usr/lib/systemd...
per esempio io ho in:
Code: Select all
/usr/lib/systemd/system/multi-user.target.wants:
lrwxrwxrwx 1 root root 15 19 gen 23.50 dbus.service -> ../dbus.service

se può esserti utile...
axelaxel6
Simple Hen
 
Posts: 64
Joined: Mon Mar 09, 2009 11:38

Re: Configurazione di rete sparita dopo aggiornamento

Postby marco.azzalini » Wed Mar 26, 2014 9:00

Ciao, intanto grazie! :-)
In effetti io non sono ancora passato a systemd... c'era il seguente invito a farlo se si era utenti GNOME, ma usando io KDE, l'ho ignorato:

"GNOME users: please migrate to systemd now!
Starting with GNOME 3.10, we will no longer support OpenRC on systems running with GNOME."

infatti, ho controllato, e:
# eselect init list
Available init implementations:
[1] systemd
[2] sysvinit *

quindi systemctl,mi dice (giustamente):
# systemctl
Failed to get D-Bus connection: No connection to service manager.

mentre Netwotkmanager sembra girare tranquillo:
ps -ef | grep Net
root 7074 1 0 08:31 ? 00:00:00 /usr/sbin/NetworkManager --pid-file /run/NetworkManager/NetworkManager.pid

A questo punto proverò a fare lo switch su systemd e speriamo che non si rompa qualcos'altro....

ciao
Marco
marco.azzalini
Baby Hen
 
Posts: 11
Joined: Wed Mar 06, 2013 11:09

Re: Configurazione di rete sparita dopo aggiornamento

Postby axelaxel6 » Wed Mar 26, 2014 18:34

axelaxel6
Simple Hen
 
Posts: 64
Joined: Mon Mar 09, 2009 11:38

Re: Configurazione di rete sparita dopo aggiornamento

Postby marco.azzalini » Thu Mar 27, 2014 9:58

Ciao, ti ringrazio molto per tutte le dritte... le sto leggendo con attenzione, mi pare di aver già capito che le mie configurazioni di rete e VPN me le sono perse :-( pazienza... le rifarò.

Ti faccio sapere come va il passaggio a systemd ...
ciao
Marco
marco.azzalini
Baby Hen
 
Posts: 11
Joined: Wed Mar 06, 2013 11:09

Next

Return to Sabayon Linux Discussioni Generali

Who is online

Users browsing this forum: No registered users and 2 guests