openfoam e gcc

Tutto ciò che è pertinente a Sabayon Linux, indipendentemente dall'architettura e dall'ambiente grafico

Moderator: Moderators

openfoam e gcc

Postby aezio » Thu Dec 05, 2013 13:41

Ciao, ho chiesto anche nella sezione in inglese, ma senza grossi risultati.

Ho cercato di installare openfoam da equo (versione 2.1.1), ma ottengo questo errore relatico a gcc. Il problemae' che ho installato gcc 4.7.3, quindi soddisfo il requisito gcc>4.3

x86_64-pc-linux-gnu-cpp: error: /usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/vanilla.specs: No such file or directory
* ERROR: sci-libs/openfoam-2.1.1::gentoo failed (setup phase):
* openfoam requires >=sys-devel/gcc-4.3 to compile.
*
* Call stack:
* ebuild.sh, line 93: Called pkg_setup
* environment, line 2228: Called die
* The specific snippet of code:
* die "${PN} requires >=sys-devel/gcc-4.3 to compile.";
*
* If you need support, post the output of `emerge --info '=sci-libs/openfoam-2.1.1::gentoo'`,
* the complete build log and the output of `emerge -pqv '=sci-libs/openfoam-2.1.1::gentoo'`.
* The complete build log is located at '/var/tmp/entropy/packages/amd64/5/sci-libs_openfoam-2.1.1_1.tbz2/portage/sci-libs/openfoam-2.1.1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/entropy/packages/amd64/5/sci-libs_openfoam-2.1.1_1.tbz2/portage/sci-libs/openfoam-2.1.1/temp/environment'.
* Working directory: '/usr/lib64/portage/pym'
* S: '/var/tmp/entropy/packages/amd64/5/sci-libs_openfoam-2.1.1_1.tbz2/portage/sci-libs/openfoam-2.1.1/work/openfoam-2.1.1'


Ho trovato qualche info ma tutte su gentoo e che usano, chiaramente, emerge. Ho letto che in geenrale e' una pessima cosa fare questo mix...
aezio
Baby Hen
 
Posts: 11
Joined: Wed Oct 02, 2013 14:14

Return to Sabayon Linux Discussioni Generali

Who is online

Users browsing this forum: No registered users and 1 guest