Due piccoli problemi (LLVM e repository)

Tutto ciò che è pertinente a Sabayon Linux, indipendentemente dall'architettura e dall'ambiente grafico

Moderator: Moderators

Due piccoli problemi (LLVM e repository)

Postby apaz » Wed Nov 27, 2013 10:06

Salve,
Vi espongo due problemi sperando che qualcuno possa chiarirmi le idee:
1- dopo l'aggiornamento della settimana scorsa (tutto funziona regolarmente) lanciando il comando "equo libtest" ottengo la sfilza di errori seguenti riguardanti LLVM:

Code: Select all
paz # equo lt --ask
>>  @@ Test librerie
>>  @@ ignoramento directory: /usr/lib64, perché ha un link simbolico su: /usr/lib
>>  @@ ignoramento directory: /lib64, perché ha un link simbolico su: /lib
>>  @@ Collezione eseguibili danneggiati
>>  @@ Attenzione: non preoccuparti di librerie segnalate qui ma non successivamente.
>>    (1.1%) /usr/lib/mesa/i915g_dri.so [ libLLVM-3.3.so ]
>>    (2.9%) /usr/lib/libXvMCsoftpipe.so.1 [ libLLVM-3.3.so ]
>>    (7.1%) /usr/lib/libXvMCsoftpipe.so.1.0.0 [ libLLVM-3.3.so ]
>>    (10.0%) /usr/lib32/libXvMCsoftpipe.so.1 [ libLLVM-3.3.so ]
>>    (14.4%) /usr/lib/icedtea7/jre/lib/amd64/libjawt.so [ libmawt.so ]
>>    (26.1%) /usr/lib32/vdpau/libvdpau_softpipe.so [ libLLVM-3.3.so ]
>>    (27.7%) /usr/lib32/cairo/libcairo-trace.so.0.0.0 [ libbfd-2.23.1.so ]
>>    (28.4%) /usr/lib/dri/i915g_dri.so [ libLLVM-3.3.so ]
>>    (31.8%) /usr/lib32/vdpau/libvdpau_softpipe.so.1 [ libLLVM-3.3.so ]
>>    (34.2%) /usr/lib32/vdpau/libvdpau_softpipe.so.1.0.0 [ libLLVM-3.3.so ]
>>    (37.3%) /usr/lib32/cairo/libcairo-trace.so [ libbfd-2.23.1.so ]
>>    (43.5%) /usr/lib32/dri/i915_dri.so [ libLLVM-3.3.so ]
>>    (43.7%) /usr/lib/gstreamer-0.10/libgstsouphttpsrc.so [ libsoup-gnome-2.4.so.1 ]
>>    (44.5%) /usr/lib/firefox/browser/components/libbrowsercomps.so [ libmozalloc.so :: libxul.so ]
>>    (51.8%) /usr/lib/vdpau/libvdpau_softpipe.so.1 [ libLLVM-3.3.so ]
>>    (52.9%) /usr/lib32/cairo/libcairo-trace.so.0 [ libbfd-2.23.1.so ]
>>    (53.3%) /usr/lib/vdpau/libvdpau_softpipe.so [ libLLVM-3.3.so ]
>>    (57.7%) /usr/lib/firefox/components/libmozgnome.so [ libmozalloc.so :: libxul.so ]
>>    (60.7%) /usr/lib/xorg/modules/drivers/i915_drv.so [ libLLVM-3.3.so ]
>>    (61.3%) /usr/lib/vdpau/libvdpau_softpipe.so.1.0.0 [ libLLVM-3.3.so ]
>>    (64.3%) /usr/lib32/dri/i915g_dri.so [ libLLVM-3.3.so ]
>>    (65.9%) /usr/lib32/libXvMCsoftpipe.so.1.0.0 [ libLLVM-3.3.so ]
>>    (70.8%) /usr/lib/libXvMCsoftpipe.so [ libLLVM-3.3.so ]
>>    (71.7%) /usr/lib/firefox/components/libdbusservice.so [ libmozalloc.so :: libxul.so ]
>>    (73.5%) /usr/lib32/mesa/i915g_dri.so [ libLLVM-3.3.so ]
>>    (92.1%) /usr/lib32/libXvMCsoftpipe.so [ libLLVM-3.3.so ]
>>  @@ Accoppiamento librerie/eseguibili danneggiati
>>  @@ Il Sistema è sano.

Che vuol dire? magari che sarà usato LLVM al posto di GCC ma per ora è in fase di prova?

2- Invece durante quest'ultimo aggiornamento, per quasi tutti i pacchetti processati ottengo questo errore (anche se poi l'installazione sembra andare in porto):
Code: Select all
paz # equo rescue spmsync --ask
>>  @@ Scansione della repository del Source Package Manager...!!! Repository 'user_defined' is missing masters attribute in '/usr/local/portage/metadata/layout.conf'
!!! Set 'masters = gentoo' in this file for future compatibility
>> Niente da fare
paz paz #


Ho riportato l'errore per "equo rescue spmsync" ma lo da' per quasi tutti i pacchetti installati durante l'aggiornamento.
Quest'ultimo problema mi sembra più preoccupante. Da notare che in "/usr/local/portage/" non c'è la directory "metadata" per cui non esiste nemmeno il file "layout.conf".
Cosa fare? Come impostare "master=gentoo"? C'è davvero bisogno di farlo o riguarda solo portage (che non uso) e non entropy?
Ringrazio sperando che qualcuno mi sappia aiutare.

Andrea
apaz
Simple Hen
 
Posts: 81
Joined: Wed Apr 07, 2010 19:04

Re: Due piccoli problemi (LLVM e repository)

Postby sabayonino » Wed Nov 27, 2013 13:32

1.
Il Sistema è sano.


quindi sembra OK


2. é un messaggio di portage durante la compilazione dei binari.

puoi provare a fare un sync di portage (anche se non usi) ed eventualmente impostare la variabile nel file indicato (o crearlo)

Code: Select all
# emerge --sync


(ovviamente ignora tutti gli update che ti propone)

ciao
User avatar
sabayonino
Sagely Hen
 
Posts: 2584
Joined: Sun Sep 21, 2008 1:12
Location: Italy

Re: Due piccoli problemi (LLVM e repository)

Postby apaz » Wed Nov 27, 2013 14:21

Ciao,
I collegamenti mancanti in libtest non mi preoccupano perché tutto funziona bene. Mi chiedevo se questa grande quantità di messaggi significasse una prossima adozione di LLVM al posto di GCC.
Invece per qunto riguarda i messaggi di portage, un poco mi preoccupano perché è la prima volta che mi capitano e non li capisco bene. Anche se uso entropy con equo, faccio sempre un "emerge --sync && layman -S" e poi, dopo gli aggiornamenti, faccio sempre "equo deptest --ask"; "equo libtest --ask" e "equo rescue spmsync --ask".
Forse è dovuto all'aggiornamento di portage che ha introdotto qualche nuova caratteristica che in Sabayon non è prevista o supportata (usando entropy, ovviamente).
A qualche altro è successo?

Andrea
apaz
Simple Hen
 
Posts: 81
Joined: Wed Apr 07, 2010 19:04

Re: Due piccoli problemi (LLVM e repository)

Postby Aquila » Tue Dec 17, 2013 13:25

Potrebbe avere a che fare con questa risposta che ho ricevuto sul forum internazionale a proposito dell'installazione della ISO 64 bit Xfce:
Hi Aquila,

you can safely ignore this warning (at least to my knowledge and past experience). I do not know why this LVM metadaemon is installed and active by default, for desktop systems it does not make much sense not even if you actually use LVMs for your partitioning setup (As I do). I received the same warning after my first install of Sabayon and I asked a Linux sysadmin about it, who told me that this daemon is meant for large scale Linux environments (clustered file systems above all) to monitor whether all volume groups and logical volumes in use work flawlessly. For a desktop system this is total overkill.

In case you still get this warning after install, for example when checking partitions or tinkering with them, you can either deactivate the daemon in /etc/lvm/lvm.conf or simply remove the lvmmetadaemon via the package management, I do not see why one would need this on a desktop system (But I may be wrong of course!)
Vedi tu se ti torna utile. Ciao.
Aquila
Young Hen
 
Posts: 38
Joined: Sun Oct 06, 2013 20:00


Return to Sabayon Linux Discussioni Generali

Who is online

Users browsing this forum: No registered users and 1 guest