[edit]Virtualbox...questo sconosciuto

Tutto ciò che è pertinente a Sabayon Linux, indipendentemente dall'architettura e dall'ambiente grafico

Moderator: Moderators

[edit]Virtualbox...questo sconosciuto

Postby agge92 » Sun Oct 06, 2013 11:23

Ho un problema con virtualbox, poichè non mi permette di installare l'sdk di sailfiskOS , più in particolare mi da rogna sul HostAudioNotRespondin durante l'installazione di mer VM, ovviamente ho già installato come nella guida col kernel aggiornato virtualbox-bin, ED stranamente quando cerco di avviare Oracle xVM VirtualBox mi dà errore all'avvio: Creazionee dell'oggetto COM VirtualBox non riuscita. e nei dettagli esce questo:
RC Chiamante:
NS_ERROR_FACTORY_NOT_REGISTERED (0x80040154)

....qualcuno ha idea di che cosa prende a VB? e come "aggiustarlo"?

EDIT: qualche persona della community di sviluppo di sailfishOS mi ha suggerito se tengo installato vboxdrv, ed andando a scovare per il sistema non trovo neanche la cartella di installazione di questo componente nelle locazioni da loro suggerite, e da terminale provando a fare sudo equo install vboxdrv , nei repository non esiste questo componente....qualcuno mi può aiutare a trovarlo e installarlo?(perchè credo sia questo il mio problema, mi manca quella "dipendenza" se non mi sto sbagliando)
agge92
Baby Hen
 
Posts: 14
Joined: Fri Jul 19, 2013 10:41

Re: [edit]Virtualbox...questo sconosciuto

Postby micia » Mon Oct 07, 2013 13:27

Ciao,

non è che per caso intendono il modulo vboxdrv?
Prova a eseguire:
(come root)
Code: Select all
modprobe vboxdrv
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: [edit]Virtualbox...questo sconosciuto

Postby agge92 » Mon Oct 07, 2013 17:03

comando eseguito, non mi ha restituito nessuno risultato....significa che ho già installato questo vboxdrv?
agge92
Baby Hen
 
Posts: 14
Joined: Fri Jul 19, 2013 10:41

Re: [edit]Virtualbox...questo sconosciuto

Postby micia » Tue Oct 08, 2013 11:16

Non necessariamente, nel terminale di solito quando non ti viene stampato nessun messaggio di errore, vuol dire che tutto è andato bene, quindi o il modulo era già caricato, o lo ha caricato correttamente.
Il comando modprobe carica dei moduli nel kernel (l'analogo dei driver Windows), in questo caso stai caricando il modulo vboxdrv che presumibilmente serve a VirtualBox per funzionare.
Prova a caricare quel modulo e a verificare se la procedura con xVM dia sempre errori, se continua a darli non era quello il problema.

Nota che modprobe non sopravvive al riavvio, ovvero se riavvii il sistema dovrai ri-eseguire:
(come root)
Code: Select all
modprobe vboxdrv
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41


Return to Sabayon Linux Discussioni Generali

Who is online

Users browsing this forum: No registered users and 1 guest