Driver nvidia non attivi

Tutto ciò che è pertinente a Sabayon Linux, indipendentemente dall'architettura e dall'ambiente grafico

Moderator: Moderators

Provia
Advanced Hen
Posts: 209
Joined: Mon Nov 26, 2012 23:15
Location: Italy

Re: Driver nvidia non attivi

Post by Provia » Tue Feb 19, 2013 10:35

Ok fammi sapere. Anche a me Sabayon 10 puntava sui driver nouveau anziché sui proprietari. Facendo come ti ho detto però ho risolto.
AMD Athlon(tm) II X2 250 Processor
4 GB DDR3 1600 Mhz
Nvidia Geforce 9800 GT
Sabayon Linux x64 KDE Limbo

User avatar
sabayonino
Sagely Hen
Posts: 3190
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: Driver nvidia non attivi

Post by sabayonino » Tue Feb 19, 2013 12:47

andrea90 wrote:Ciao Provia
vedo che si blocca su virtualGL.

controllato se

virtual/opengl

è installato ? :roll:
[Che Cos'è Il Calcolo Distribuito (BOINC)

BOINC ready ! Sabayon+BOINC = BILD ,my Sabayon spin :cyclops: - Ready to crunch for the Science everywhere :)

andrea90
Baby Hen
Posts: 8
Joined: Tue Jan 29, 2013 12:40

Re: Driver nvidia non attivi

Post by andrea90 » Thu Feb 21, 2013 15:48

Ciao,
ho controllato ed entrambi risultano correttamente installati e aggiornati.

Provia
Advanced Hen
Posts: 209
Joined: Mon Nov 26, 2012 23:15
Location: Italy

Re: Driver nvidia non attivi

Post by Provia » Thu Feb 21, 2013 18:57

Dando sudo eselect set nvidia che cosa riporta la console? Effetua lo switch normalmente?
AMD Athlon(tm) II X2 250 Processor
4 GB DDR3 1600 Mhz
Nvidia Geforce 9800 GT
Sabayon Linux x64 KDE Limbo

andrea90
Baby Hen
Posts: 8
Joined: Tue Jan 29, 2013 12:40

Re: Driver nvidia non attivi

Post by andrea90 » Fri Feb 22, 2013 11:05

Code: Select all

andrea-PC andrea # eselect opengl set nvidia
Switching to nvidia OpenGL interface... done
andrea-PC andrea # eselect opengl list
Available OpenGL implementations:
  [1]   nvidia *
  [2]   xorg-x11
  [3]   ati

Provia
Advanced Hen
Posts: 209
Joined: Mon Nov 26, 2012 23:15
Location: Italy

Re: Driver nvidia non attivi

Post by Provia » Fri Feb 22, 2013 16:19

Scusa magari l'hai già riportato ma non ho capito di che scheda video stiamo parlando. Mi sembra piuttosto strano. Hai provato anche con un "sudo equo deptest" per verificare eventuali pacchetti mancanti? In ogni caso io farei anche una prova radicale facendo un upgrade del kernel(ovviamente con lo script kernel-switcher) e quindi dei driver.
Fammi sapere :).
AMD Athlon(tm) II X2 250 Processor
4 GB DDR3 1600 Mhz
Nvidia Geforce 9800 GT
Sabayon Linux x64 KDE Limbo

andrea90
Baby Hen
Posts: 8
Joined: Tue Jan 29, 2013 12:40

Re: Driver nvidia non attivi

Post by andrea90 » Mon Feb 25, 2013 8:57

La mia sheda video è

Code: Select all

3D controller: NVIDIA Corporation GF108 [GeForce GT 540M]

Code: Select all

andrea-PC andrea # equo deptest
>>  @@ Esecuzione test dipendenze...
>>  @@ Queste sono le dipendenze non trovate:
>>    # >=app-admin/eselect-boost-0.3
>>       # Richiesto da:
>>       # dev-libs/boost-1.46.1-r1
>>  @@ Installazione pacchetti disponibili in 10 secondi ...
>> Nessun pacchetto trovato.
(1, False)
Uso il kernel 3.7.0. Se è possibile aggiornarlo, come si fa con kernel-switcher?

Provia
Advanced Hen
Posts: 209
Joined: Mon Nov 26, 2012 23:15
Location: Italy

Re: Driver nvidia non attivi

Post by Provia » Mon Feb 25, 2013 9:46

mmmm....io non sono un esperto non so bene cosa potrebbe essere...di solito gli step sono
-installare il driver (magari controlla di non averne due versione installate per lo stesso kernel)
-dare il comando per configurare xorg
-fare l'eselect per le opengl
a te pare sia andato tutto eppure non funziona. Non so bene cosa consigliarti però potresti fare un ulteriore prova con il live cd di SL 11 e vedere con "eselect opengl list" se riconosce i driver proprietari o meno.
AMD Athlon(tm) II X2 250 Processor
4 GB DDR3 1600 Mhz
Nvidia Geforce 9800 GT
Sabayon Linux x64 KDE Limbo

Post Reply