Nuova installazione di Gambas [Risolto]

Tutto ciò che è pertinente a Sabayon Linux, indipendentemente dall'architettura e dall'ambiente grafico

Moderator: Moderators

Re: Nuova installazione di Gambas

Postby back_os » Wed Nov 21, 2012 15:57

la lista di gambas-sourceforge, nella riga "gb.db.postgresql------------>libpq.so" indica il riferimento alla libreria libpq.so. Tu hai riportato nel comando Shell il termine libpqxx. Ma come sei risalito da libpq.so a libpqxx?


la lista del sito di gambas riporta un elenco di librerie e pacchetti debian like.
noi sabayonisti/gentoisti dobbiamo andare a cercare il corrispondente per la nostra distro.
Image
back_os
Baby Hen
 
Posts: 15
Joined: Tue Nov 20, 2012 9:36
Location: Back


Re: Nuova installazione di Gambas

Postby micia » Wed Nov 21, 2012 18:48

sabayonino, non lo ha ancora installato, è lo script configure che si adatta automaticamente alle librerie che trova il problema, non si capisce come soddisfare i requisiti per ciascun modulo. :mrgreen:
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: Nuova installazione di Gambas

Postby picavbg » Wed Nov 21, 2012 21:59

micia wrote:sabayonino, non lo ha ancora installato, è lo script configure che si adatta automaticamente alle librerie che trova il problema, non si capisce come soddisfare i requisiti per ciascun modulo. :mrgreen:


Riprendo codesta ultima citazione soltanto per precisare che sono io a non capire come soddisfare i requisiti per ciascun modulo,. Infatti sto rispondendo a tutti, perchè la strada indicata da back_os è quella giusta: lo dimostra l'esito ottenuto dopo avere installato le librerie gb.db.postgresql (pacchetto) lbpq col comando
Code: Select all
# equo install dev-libs/libpqxx
dove libpqxx è il nome-pacchetto-di-sviluppo corrispondente nella distro Sabayon.
Ho rieseguito, dopo l'installazione del suddetto pacchetto i comandi "./reconf-all" e "./configure -C".
Effettivamente la lista dei componenti disabilitati è dimnuita di 1, passando dagli 8 precdenti a 7.
Occorre perciò trovare i nomi corrispondenti alle altre librerie volute da gambas. Per altre distro come ArchLinux, Debian, Fedora, Mageia, Mandriva, OpenSuse, Ubuntu, sono già indicate nella docuimentazione ufficiale di Gambas. Per Sabayon non so come potervi risalire. Gli indizi fornitimi graziosamente da back_os purtroppo a me dicono ben poco, a causa della quasi non conoscenza di tutto l'ambiente Sabayon, nè vi sono riuscito con ricerche di parole, considerate da come parole-chiave, in questo sito.
Ora so soltanto che la strada da seguire è proprio quella di trovare ed installare le benedette/maledette librerie a me mancanti.
in pratica, dovrei trovare i nomi dei pacchetti di sviluppo corrispondenti alle librerie:
gb.gtk.opengl,
gb.jit
gb.qt4, gb.qt4.ext, gb.qt4.opengl, gb.qt4.webkit
gb.sdl


A parte ciò, sono già contento di avere capito da dove partire. :cyclops:
Ciao.
picavbg
Simple Hen
 
Posts: 66
Joined: Thu May 31, 2012 8:38

Re: Nuova installazione di Gambas

Postby picavbg » Thu Nov 22, 2012 0:19

Spero di avere trovato la strada per ottenere i nomi dei file da scorrere per trovare quelli che mi servono. Solo che mi occorrerebbe capire come potere ottenere un file leggibile che ho tentato di scrivere col seguente comando:
Code: Select all
# equo search dev-
········ bla ········ bla ········ bla ········ bla ········ bla ········ bla ········
 @@ Pacchetto: x11-drivers/xf86-input-evdev-2.7.3 branch: 5, [sabayon-weekly]
>>         Disponibile:   versione: 2.7.3 ~ tag: NoTag ~ revisione: 0
>>         Installato:    versione: 2.7.3 ~ tag: NoTag ~ revisione: 0
>>         Slot:          0
>>         Homepage:      http://xorg.freedesktop.org/
>>         Descrizione:   Generic Linux input driver
>>         Licenza:       MIT
>>      @@ Pacchetto: x11-drivers/xf86-video-fbdev-0.4.3 branch: 5, [sabayon-weekly]
>>         Disponibile:   versione: 0.4.3 ~ tag: NoTag ~ revisione: 2
>>         Installato:    versione: 0.4.3 ~ tag: NoTag ~ revisione: 2
>>         Slot:          0
>>         Homepage:      http://xorg.freedesktop.org/
>>         Descrizione:   video driver for framebuffer device
>>         Licenza:       MIT
>>  Keyword:  dev-
>>  Trovati:  3532 entries
# equo search dev- > /home/piersab/Desktop/Sabayon_Elenco_dev
quelle riportate sopra sono solamente le ultime righe del comando dato la prima volta, cioé senza reindirizzamento. Il file che ho ottenuto alla fine risulta assolutamente illeggibile, sia con gedit che con libreoffice. Come posso leggerlo?
Buona notte.
picavbg
Simple Hen
 
Posts: 66
Joined: Thu May 31, 2012 8:38

Re: Nuova installazione di Gambas

Postby back_os » Thu Nov 22, 2012 9:05

forse non sono stato abbastanza chiaro.
devi trovare i pacchetti e non le librerie nei repo di sabayon.

ti faccio il primo esempio.

Code: Select all
gb.gtk.opengl


questa libreria, secondo quella benedetta lista su gambas, corrisponde a:

Code: Select all
gb.gtk.opengl -------->   gtkglext-1.0

per cui ti basta dare:

Code: Select all
equo install x11-libs/gtkglext


continuiamo.....

la libreria gb.jit corrisponde a :

Code: Select all
gb.jit ------->   LLVM >= 3.1


Code: Select all
equo install sys-devel/llvm


e così via.
Image
back_os
Baby Hen
 
Posts: 15
Joined: Tue Nov 20, 2012 9:36
Location: Back

Re: Nuova installazione di Gambas

Postby picavbg » Thu Nov 22, 2012 9:32

back_os wrote:forse non sono stato abbastanza chiaro.
devi trovare i pacchetti e non le librerie nei repo di sabayon.

Non avevo capito. Ciò però significa che manca una chiave di lettura in quel che bisogna installare. Il vuoto da coprire è sempre lo stesso come risalire al nome del pacchetto. Si possono elencare i pacchetti disponibili nei repository per eventuali installazioni?
Ciao.
picavbg
Simple Hen
 
Posts: 66
Joined: Thu May 31, 2012 8:38

Re: Nuova installazione di Gambas

Postby back_os » Sat Nov 24, 2012 11:17

hai installato i 2 pacchetti che ti ho consigliato?
stai cercando di andare avanti?
Image
back_os
Baby Hen
 
Posts: 15
Joined: Tue Nov 20, 2012 9:36
Location: Back

Re: Nuova installazione di Gambas

Postby picavbg » Sun Nov 25, 2012 18:56

back_os wrote:hai installato i 2 pacchetti che ti ho consigliato?
stai cercando di andare avanti?


Si, ho installato tutti i pacchetti occorrenti, sia quelli che mi hai indicato tu sia quegli altri che mi hai lasciato il compito di cercare. Dal risultato finale,
Code: Select all
||
|| ALL COMPONENTS WILL BE COMPILED
||
sembra che il compito l'abbia svolto bene. :D

Visto che ormai restava solamente da fare gli ultimi due passi per disporre dell'ambiaente gambas, ho eseguito acnhe
Code: Select all
$ Make
··························
Making all in src
make[4]: Entering directory `/home/piersab/gambas3-sorgenti/gambas3-3.3.3/gb.gsl/src'
  CC     gb_gsl_la-main.lo
  CC     gb_gsl_la-c_gsl.lo
  CC     gb_gsl_la-c_complex.lo
  CC     gb_gsl_la-c_vector.lo
  CC     gb_gsl_la-c_matrix.lo
  CC     gb_gsl_la-c_polynomial.lo
  CCLD   gb.gsl.la
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -latlas
collect2: ld returned 1 exit status
make[4]: *** [gb.gsl.la] Errore 1
make[4]: Leaving directory `/home/piersab/gambas3-sorgenti/gambas3-3.3.3/gb.gsl/src'
make[3]: *** [all-recursive] Errore 1
make[3]: Leaving directory `/home/piersab/gambas3-sorgenti/gambas3-3.3.3/gb.gsl'
make[2]: *** [all] Errore 2
make[2]: Leaving directory `/home/piersab/gambas3-sorgenti/gambas3-3.3.3/gb.gsl'
make[1]: *** [all-recursive] Errore 1
make[1]: Leaving directory `/home/piersab/gambas3-sorgenti/gambas3-3.3.3'
make: *** [all] Errore 2

Però, come hai potuto constatare gli ostacoli non sono ancora terminati. :(
Ciao.
picavbg
Simple Hen
 
Posts: 66
Joined: Thu May 31, 2012 8:38

Re: Nuova installazione di Gambas

Postby micia » Sun Nov 25, 2012 19:07

Questo è abbastanza semplice da risolvere:
(come root)
Code: Select all
equo install blas-atlas

dovrebbe risolverlo.
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

PreviousNext

Return to Sabayon Linux Discussioni Generali

Who is online

Users browsing this forum: No registered users and 1 guest

cron