Problema con Sulfur

Tutto ciò che è pertinente a Sabayon Linux, indipendentemente dall'architettura e dall'ambiente grafico

Moderator: Moderators

Re: Problema con Sulfur

Postby afullo » Sat Jun 25, 2011 13:47

Code: Select all
afullo@afullo ~ $ eselect python list
Available Python interpreters:
  [1]   python2.6
  [2]   python2.7 *


Installando VTE ora Entropy parte, speriamo in bene. Grazie intanto. :D

ps: prima di eseguire il comando equo come root l'ho per errore eseguito come utente normale e mi ha fatto vedere qualcosa utilizzando pretend. Si è trattata soltanto di una simulazione come il nome stesso parrebbe suggerire?
afullo
Baby Hen
 
Posts: 16
Joined: Sun Aug 08, 2010 12:48

Re: Problema con Sulfur

Postby micia » Sat Jun 25, 2011 13:53

Si, è esattamente cosi, quando usi i comandi di entropy come utente normale verrà eseguita solo una simulazione, dato che solo l'utente di root ha i permessi di installare pacchetti.

Comunque i tuoi problemi son chiaramente legati all'aggiornamento di python da 2.6 a 2.7. Teoricamente tu ora dovresti poter rimuovere la versione vecchia di python:
(come root)
Code: Select all
equo remove --deep --configfiles --ask python:2.6

dato che è inutile e occupa un po' di spazio, potresti provare ad eseguire quel comando, fermandoti alla domanda che ti fa dopo la risoluzione delle dipendenze e scrivere qui i pacchetti che ti vorrebbe rimuovere?
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: Problema con Sulfur

Postby afullo » Sat Jun 25, 2011 13:58

Hmm, a dire il vero ora ho già iniziato l'aggiornamento del sistema con Entropy, sono ancora in tempo per agire da terminale senza sovrapporre le due cose, perché come Ubuntu prima scarica tutto e poi installa tutto, o mi conviene aspettare la fine della procedura, magari perché inizia ad installare qualcosa nel mentre scarica? ;)
afullo
Baby Hen
 
Posts: 16
Joined: Sun Aug 08, 2010 12:48

Re: Problema con Sulfur

Postby micia » Sat Jun 25, 2011 14:00

Fai pure :)
finisci tutto quel che devi, una volta fatto, prova il comando che ti ho detto.

Credo che entropy si rifiuterebbe di eseguire l'azione se è in corso un'altra operazione di installazione.
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: Problema con Sulfur

Postby afullo » Sat Jun 25, 2011 15:50

Aggiornamento completato, ho riavviato e mi dice che effettivamente non ci sono ulteriori aggiornamenti. :D

Ecco qui quanto a Python: :)

Code: Select all
afullo afullo # equo remove --deep --configfiles --ask python:2.6
>>  @@ Questi sono i pacchetti scelti:
>>    # (1/1) [sabayonlinux.org] dev-lang/python-2.6.6-r1 [27.4MB]
>>  @@ Pacchetti coinvolti: 1
     Vuoi continuare con il calcolo delle dipendenze ? [Si/No]


Per il resto, come posso accertarmi che la mia Sabayon sia stata effettivamente aggiornata alla versione 6, e che non sia semplicemente andata alla più recente della serie delle 5.x? Ho provato con comandi quali ver, version, rel, release, ma non è uno di questi. ;)
afullo
Baby Hen
 
Posts: 16
Joined: Sun Aug 08, 2010 12:48

Re: Problema con Sulfur

Postby micia » Sat Jun 25, 2011 18:58

Puoi controllare cosi:
Code: Select all
cat /etc/sabayon-release

Comunque è sicuro, dato che Sabayon è una rolling distro, le versioni sono lì solo per riferimento :mrgreen:
Quello potrebbe accadere se Sabayon 6 fosse su un altro branch di entropy (in tal caso dovresti usare equo hop per cambiare branch).

L'output mi servirebbe dello stadio successivo a quello che hai messo, ovvero, dopo che rispondi 'si' a quella domanda, per vedere quali altri pacchetti vengono coinvolti.
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: Problema con Sulfur

Postby afullo » Sat Jun 25, 2011 21:01

Ecco a te. La versione è quella giusta, al passo successivo mi ha visualizzato questo:

Code: Select all
afullo@afullo ~ $ cat /etc/sabayon-release
Sabayon Linux x86 6

afullo afullo # equo remove --deep --configfiles --ask python:2.6
>>  @@ Questi sono i pacchetti scelti:
>>    # (1/1) [sabayonlinux.org] dev-lang/python-2.6.6-r1 [27.4MB]
>>  @@ Pacchetti coinvolti: 1
     Vuoi continuare con il calcolo delle dipendenze ? [Si/No] Si
>>  @@ Questi sono i pacchetti che vorrebbero essere rimossi:
>>  ## [sabayonlinux.org] dev-libs/boost-1.41.0-r2 [91.0MB]
>>  ## [sabayonlinux.org] dev-lang/python-2.6.6-r1 [27.4MB]
>>  ## [sabayonlinux.org] app-admin/python-updater-0.8-r1 [766.2kB]
>>  @@ Pacchetti da rimuovere: 3
>>  @@ Spazio su disco liberato: 119.2MB
>>  @@ Spazio totale sprecato: 18.6MB
     Vuoi procedere ? [Si/No]
afullo
Baby Hen
 
Posts: 16
Joined: Sun Aug 08, 2010 12:48

Re: Problema con Sulfur

Postby micia » Sat Jun 25, 2011 22:36

Direi che lo puoi disinstallare, anche se python-updater lo terrei, è uno strumento di portage, quindi se non hai in mente di usare emerge, potresti anche eliminare pure lui.
A te la scelta :mrgreen:

Se vuoi risparmiare un po' di spazio, ti consiglio di eliminare python-2.6.
fossi in te farei cosi:
(come root)
Code: Select all
equo remove --deep --configfiles --ask python:2.6
equo deptest && equo libtest

se ti interessa python-updater, dopo tutta questa faccenda:
(come root)
Code: Select all
equo install python-updater
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Previous

Return to Sabayon Linux Discussioni Generali

Who is online

Users browsing this forum: No registered users and 1 guest