equo in crash [Risolto]

Tutto ciò che è pertinente a Sabayon Linux, indipendentemente dall'architettura e dall'ambiente grafico

Moderator: Moderators

Re: equo in crash

Postby micia » Tue Jun 14, 2011 14:28

Si, una versione di un sistema x86 gira anche su processori AMD64, molto spesso, infatti, le copie di Windows in OEM che ti vengono installate sui portatili sono a 32 bit anche se il computer ha effettivamente una CPU a 64 bit.
Naturalmente se il sistema è in versione x86, non sfrutta le piene potenzialità del tuo processore.
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: equo in crash

Postby Alessio » Tue Jun 14, 2011 16:35

Ok, comunque credo di avere un altro problema legato alla scheda grafica: :mrgreen:
Code: Select all
[email protected] ~ $ glxinfo
name of display: :0.0
Segmentation fault

Esattamente come l'altra volta! Solo che:
Code: Select all
[email protected] ~ $ eselect opengl list
Available OpenGL implementations:
    [1]  ati
    [2]  xorg-x11*

Ho anche modificato il file "xorg.conf" rimuovendo la parte
Code: Select all
Section "Device"

Identifier "SabayonVga1"
Driver "fglrx"
BusID "PCI:01:00"
#Option "RenderAccel" "on"
#Option "XAANoOffscreenPixmaps"
#Option "BusType" "PCI"
#Option "ColorTiling" "on"
#Option "EnablePageFlip" "on"
Option "UseEvents" "True"
Option "LogoPath" "/usr/share/backgrounds/sabayonlinux-nvidia.png"

EndSection

Inoltre
Code: Select all
glxinfo | grep vendor
glxinfo | grep render

non mi danno nessun output! :shock:
Da quello che ho capito, ho disabilitato i driver ATI (in pratica non li sto usando), ma c'è un errore negli altri driver o nella loro installazione.... Come posso fare a risolvere? Ho appena finito di scaricare gli aggiornamenti, ma non mi fido proprio a riavviare...
Alessio
Growing Hen
 
Posts: 168
Joined: Mon May 02, 2011 14:14

Re: equo in crash

Postby micia » Tue Jun 14, 2011 16:44

Se riavviassi ora credo che avresti uno schermo nero, prova a fare cosi:
(come root)
Code: Select all
eselect opengl set ati

come vedi nel tuo xorg.conf hai i driver proprietari ATI, ma stai usando i driver open source secondo eselect, l'asterisco è accanto a xorg-x11.

Se vuoi usare la scheda integrata, nella section Device devi usare "intel" ed eselect deve rimanere cosi, in caso contrario devi usare "fglrx" nell'xorg.conf e ati in eselect, in altre parole:

Scheda intel:
eselect: xorg-x11
Section Device: intel
Scheda ATI:
eselect: ati
Section Device: fglrx

Comunque gli ultimi driver ATI pare abbiano un barlume di supporto per questo genere di PC, magari più avanti ci si potranno fare degli esperimenti :mrgreen:
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: equo in crash

Postby Alessio » Tue Jun 14, 2011 16:57

Ma non ho i driver ATI: ho rimosso la parte che ho citato sopra! Ti posto il file /etc/X11/xorg.conf:
Code: Select all
Section "Module"
    SubSection  "extmod"
       Option    "omit xfree86-dga"
    EndSubSection
    Load    "i2c"
    Load    "ddc"
    Load    "vbe"
    Load    "dri"
    Load    "glx"
    Load    "synaptics"
EndSection

Section "ServerFlags"
     Option    "AllowMouseOpenFail"    "true"
EndSection

Section "Monitor"
    Identifier    "Generic Monitor"
    VertRefresh    43 - 60
    HorizSync      28 - 80
EndSection


Section "Device"

    Identifier  "SabayonVga0"
    Driver      "intel"
    BusID    "PCI:00:02"
    #Option "RenderAccel" "on"
    #Option "XAANoOffscreenPixmaps"
    #Option "BusType" "PCI"
    #Option "ColorTiling" "on"
    #Option "EnablePageFlip" "on"
    Option "UseEvents" "True"
    Option "LogoPath" "/usr/share/backgrounds/sabayonlinux-nvidia.png"

EndSection
   


Section "Screen"

    Identifier    "Screen 0"
    Device        "SabayonVga0"
    Monitor       "Generic Monitor"
    #Option       "AddARGBGLXVisuals" "true"

    DefaultDepth 24

    SubSection "Display"
        Depth      8
        ViewPort   0 0
        #Modes      "1024x768" "800x600" "640x480"
    EndSubsection

    SubSection "Display"
        Depth           16
        ViewPort        0 0
        #Modes      "1024x768" "800x600" "640x480"
    EndSubsection

    SubSection "Display"
        Depth           24
        ViewPort        0 0
        #Modes      "1024x768" "800x600" "640x480"
    EndSubsection

EndSection



Section "Screen"

    Identifier    "Screen 1"
    Device        "SabayonVga1"
    Monitor       "Generic Monitor"
    #Option       "AddARGBGLXVisuals" "true"

    DefaultDepth 24

    SubSection "Display"
        Depth      8
        ViewPort   0 0
        #Modes      "1024x768" "800x600" "640x480"
    EndSubsection

    SubSection "Display"
        Depth           16
        ViewPort        0 0
        #Modes      "1024x768" "800x600" "640x480"
    EndSubsection

    SubSection "Display"
        Depth           24
        ViewPort        0 0
        #Modes      "1024x768" "800x600" "640x480"
    EndSubsection

EndSection


Section "DRI"
    Mode 0666
EndSection

Section "ServerLayout"
    Identifier   "Main Layout"
    Screen 0    "Screen 0"
    Screen 1    "Screen 1"
EndSection

Section "Extensions"
   #Option "Composite" "Enable"
EndSection
Alessio
Growing Hen
 
Posts: 168
Joined: Mon May 02, 2011 14:14

Re: equo in crash

Postby micia » Tue Jun 14, 2011 17:03

ah, scusami, mi son perso quella insignificante frase, devo dormire di più la notte :mrgreen:

allora dovrebbe essere a posto, per quanto riguarda la grafica, al riavvio...
Almeno sembra...

Quei difetti li ha sempre fatti prima delle modifiche e del riavvio, intendo glxinfo, no?
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: equo in crash

Postby Alessio » Tue Jun 14, 2011 17:05

Non avevo mai provato prima!!! :oops:
Quindi dici che anche se glxinfo mi da:
Code: Select all
Segmentation fault

non mi devo preoccupare perchè tanto sto già usando i driver intel? Quindi posso riavviare senza problems? :?:
Alessio
Growing Hen
 
Posts: 168
Joined: Mon May 02, 2011 14:14

Re: equo in crash

Postby micia » Tue Jun 14, 2011 17:20

glxinfo dava segmentation fault anche nel primo thread a riguardo, se ricordo bene. Il problema è proprio che mi sa che non stai ancora usando i driver intel.
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: equo in crash

Postby Alessio » Tue Jun 14, 2011 17:37

E come devo fare per risolvere il problema? O basta che riavvio tutto incrociando le dita?
Alessio
Growing Hen
 
Posts: 168
Joined: Mon May 02, 2011 14:14

Re: equo in crash

Postby micia » Tue Jun 14, 2011 17:42

il problema lo stai risolvendo ora modificando quei file e riavviando, l'altra volta aveva funzionato a quanto ricordo... Incrociare le dita è stato necessario anche l'altra volta :mrgreen:
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: equo in crash

Postby Alessio » Tue Jun 14, 2011 17:50

Fatto! Tutto a posto per il momento, grazie!
Alessio
Growing Hen
 
Posts: 168
Joined: Mon May 02, 2011 14:14

PreviousNext

Return to Sabayon Linux Discussioni Generali

Who is online

Users browsing this forum: No registered users and 1 guest

cron