Problemi X Server dopo gli ultimi aggiornamenti [Risolto]

Tutto ciò che è pertinente a Sabayon Linux, indipendentemente dall'architettura e dall'ambiente grafico

Moderator: Moderators

Re: Problema filemanager

Postby micia » Sat Jun 04, 2011 11:21

Credo anche io, prova a fare cosi:
(come root)
Code: Select all
/etc/init.d/NetworkManager stop
ifconfig eth0 down
ifconfig eth0 up
dhclient eth0

poi riprova coi pacchetti, quei comandi dovrebbero impostarti manaualmente la connessione ethernet usando DHCP.
puoi provare se la connessione funziona eseguendo:
Code: Select all
ping www.google.com

quando vuoi uscire dal ping usa ctrl+C.
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: Problema filemanager

Postby Alessio » Sat Jun 04, 2011 11:28

Uguale a prima purtroppo! Se provo a dargli questo (dopo aver eseguito gli altri comandi, ovviamente):
Code: Select all
ping www.google.com
ping: unknown host www.google.com

E se provo con "equo update" mi da gli stessi errori di prima!
Alessio
Growing Hen
 
Posts: 168
Joined: Mon May 02, 2011 14:14

Re: Problema filemanager

Postby micia » Sat Jun 04, 2011 11:30

giusto per scrupolo, ti appare eth0 se esegui:
(come root)
Code: Select all
ifconfig

vero?

[Edit] dato che l'argomento sta andando eccessivamente Off Topic lo ho diviso per mantenere la cosa più ordinata.
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: Problemi avvio X Server dopo gli ultimi aggiornamenti

Postby Alessio » Sat Jun 04, 2011 11:37

Ok, no problem! Comunque, con "ifconfig", mi esce "eth0" con a fianco una serie di scritte, e sotto "lo" con a fianco un'altra serie di scritte... Devo trascrivere? :)
Alessio
Growing Hen
 
Posts: 168
Joined: Mon May 02, 2011 14:14

Re: Problemi avvio X Server dopo gli ultimi aggiornamenti

Postby micia » Sat Jun 04, 2011 11:40

Non c'è bisogno, solo che dovrebbe connettersi senza problemi non solo manualmente, ma anche automaticamente. I comandi che ti ho scritto sopra, sopratutto dhclient, ti danno qualche problema, per esempio messaggi di errore?
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: Problemi avvio X Server dopo gli ultimi aggiornamenti

Postby Alessio » Sat Jun 04, 2011 11:50

Non mi pare:
Code: Select all
dhclient
Internet Systems Consortium DHCP Client V3.1.2p1-Gentoo
Copyright 2004-2009 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/wlan0/c4:46:19:41:a7:3f
Sending on LPF/wlan0/c4:46:19:41:a7:3f
Listening on LPF/eth0/c8:0a:a9:d1:6f:e9
Sending on LPF/eth0/c8:0a:a9:d1:6f:e9
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 5
DHCPREQUEST on eth0 to 255.255.255.255 port 67
DHCPACK from 192.168.1.1
bound to 192.168.1.10 -- renewal in 37679 seconds
Alessio
Growing Hen
 
Posts: 168
Joined: Mon May 02, 2011 14:14

Re: Problemi avvio X Server dopo gli ultimi aggiornamenti

Postby micia » Sat Jun 04, 2011 11:53

Dagli anche l'interfaccia di rete su cui ascoltare, in questo modo:
Code: Select all
killall dhclient
dhclient eth0

(il primo è per eliminare tutti i client DHCP che abbiamo avviato finora)
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: Problemi avvio X Server dopo gli ultimi aggiornamenti

Postby Alessio » Sat Jun 04, 2011 11:59

Ecco qua, ma non riesco ancora ad aggiornare:
Code: Select all
athlon alessio # killall dhclient
athlon alessio #dhclient eth0
Internet Systems Consortium DHCP Client V3.1.2p1-Gentoo
Copyright 2004-2009 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth0/c8:0a:a9:d1:6f:e9
Sending on LPF/eth0/c8:0a:a9:d1:6f:e9
Sending on Socket/fallback
DHCPREQUEST on eth0 to 255.255.255.255 port 67
DHCPACK from 192.168.1.1
bound to 192.168.1.10 -- renewal in 40859 seconds
Alessio
Growing Hen
 
Posts: 168
Joined: Mon May 02, 2011 14:14

Re: Problemi avvio X Server dopo gli ultimi aggiornamenti

Postby micia » Sat Jun 04, 2011 12:07

la cosa pazzesca è che ti si connette con successo...
Come ti dice lui stesso:
bound to 192.168.1.10 -- renewal in 40859 seconds
NetworkManager è attivo?
Code: Select all
rc-status | grep NetworkManager

perché l'unica possibilità è che NetworkManager sia ancora lì a cercare di gestire la rete.

Comunque facciamo una bella cosa ora, rinunciamo all'accelerazione video mentre cerchiamo di ristabilire tutto com'era prima, prova cosi:
(come root)
Code: Select all
nano /etc/X11/xorg.conf

sostituisci nella Section Device:
Code: Select all
Driver "intel"

con:
Code: Select all
Driver "vesa"

cosi dovresti riavere una GUI.
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: Problemi avvio X Server dopo gli ultimi aggiornamenti

Postby Alessio » Sat Jun 04, 2011 12:12

NetworkManager me lo da "stopped". Ho cambiato con "vesa"... Adesso cosa devo fare? Ho riavviato, ma non è cambiato niente...
Alessio
Growing Hen
 
Posts: 168
Joined: Mon May 02, 2011 14:14

PreviousNext

Return to Sabayon Linux Discussioni Generali

Who is online

Users browsing this forum: No registered users and 1 guest