Problemi X Server dopo gli ultimi aggiornamenti [Risolto]

Tutto ciò che è pertinente a Sabayon Linux, indipendentemente dall'architettura e dall'ambiente grafico

Moderator: Moderators

Re: Problemi avvio X Server dopo gli ultimi aggiornamenti

Postby micia » Sat Jun 04, 2011 18:10

Normalmente non sono un sostenitore di questi metodi... Ma... Ti puoi permettere di reinstallare Sabayon? Tutti questi errori mi danno la sensazione di un aggiornamento o qualcosa di simile andato veramente storto.
Altrimenti penso che l'unica soluzione valida sia usare il LiveDVD di Sabayon per fare un chroot in quella installazione per avere entropy e la rete (e una GUI, che male non fa :D ) a disposizione.

Se ritieni che formattare tutto non sia accettabile, ti spiegherò come fare un chroot dal LiveDVD di Sabayon, che comunque è un esperienza utile per sapere come recuperare dati o soccorrere un sistema messo male.
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: Problemi avvio X Server dopo gli ultimi aggiornamenti

Postby alonsoty » Sat Jun 04, 2011 18:27

scusate non voglio creare altri pasticci... ma quando ho visto modem AliceADSL sono scattato!
se avete già risolto con la rete ignoratemi!!! :wink:

Cinque anni fà avevo il famelico disco volante di Alice (fortunatamente si è rotto e mi sono comprato un router serio)...
Il problema è che non era un vero router (in realtà lo era ma il firmware che ci mette Telecom lo trasforma in qualcosa d'altro).
Ricordo che con Gentoo dovevo fare la trafila di comandi (come root):
Code: Select all
# ifconfig eth0 192.168.1.15 mtu 1500 up

per usare bene il finto router/modem, poi:
Code: Select all
# modprobe pppoe
# pppoe-setup

e mettevo i parametri (nome utente etc... poi continuavo con:
Code: Select all
# pppoe-start
# /sbin/route del default
# /sbin/route add default dev pppoe


bho! :|
alonsoty
Advanced Hen
 
Posts: 236
Joined: Sat Sep 16, 2006 20:39
Location: Marchesonia - Italy

Re: Problemi avvio X Server dopo gli ultimi aggiornamenti

Postby Alessio » Sun Jun 05, 2011 15:48

Ancora niente da fare: non sono riuscito a configurare quel modem da 2 soldi, mi uscivano solo messaggi di errore! :(
Comunque ho trasferito su hard disk esterno tutti i miei dati, grazie a linux puppy. Quando avrò tempo reinstallerò Sabayon!
Grazie a tutti per l'aiuto e l'interessamento, credo che questo sia sicuramente uno dei migliori forum di supporto nel modo linux!
Alessio
Growing Hen
 
Posts: 168
Joined: Mon May 02, 2011 14:14

Re: Problemi avvio X Server dopo gli ultimi aggiornamenti

Postby Alessio » Wed Jun 08, 2011 16:42

Ciao, ho reinstallato Sabayon, adesso sta scaricando aggiornamenti... Mi ha chiesto di accettare le licenze per quei famosi microcodici che avevo installato l'altra volta. Quindi stavolta si tratta della prova del 9: se al riavvio ho problemi, probabilmente è colpa loro!
Alessio
Growing Hen
 
Posts: 168
Joined: Mon May 02, 2011 14:14

Re: Problemi avvio X Server dopo gli ultimi aggiornamenti

Postby Alessio » Wed Jun 08, 2011 17:26

Ok, aggiornamenti scaricati: tutto ok, a parte sulfur, che non parte! Ho provato con i comandi dell'altra volta, ma niente da fare! Ecco il risultato di eselect phyton list:
Code: Select all
athlon alessio #     eselect python list
Available Python interpreters:
  [1]   python2.6
  [2]   python2.7 *


[EDIT] Ho provato ad avviare sulfur da terminale:
Code: Select all
athlon alessio # gksu sulfur
**
GLib-GIO:ERROR:gdbusconnection.c:2279:initable_init: assertion failed: (connection->initialization_error == NULL)
Abortito
Alessio
Growing Hen
 
Posts: 168
Joined: Mon May 02, 2011 14:14

Re: Problemi avvio X Server dopo gli ultimi aggiornamenti

Postby micia » Wed Jun 08, 2011 17:36

non usare gksu se sei già root.
Come utente normale:
Code: Select all
gksu sulfur
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: Problemi avvio X Server dopo gli ultimi aggiornamenti

Postby Alessio » Fri Jun 10, 2011 14:22

Ok, grazie! Ecco qua:
Code: Select all
alessio@athlon ~ $     gksu sulfur
Traceback (most recent call last):
  File "/usr/lib/entropy/sulfur/sulfur_client.py", line 18, in <module>
    import gtk
ImportError: No module named gtk
Alessio
Growing Hen
 
Posts: 168
Joined: Mon May 02, 2011 14:14

Re: Problemi avvio X Server dopo gli ultimi aggiornamenti

Postby micia » Fri Jun 10, 2011 15:33

È un problema che hanno incontrato in molti, si risolve facilmente:
(come root)
Code: Select all
equo install --deep --empty pygtk

sembra sia dovuto all'aggiornamento di python da 2.6 a 2.7.
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: Problemi avvio X Server dopo gli ultimi aggiornamenti

Postby Alessio » Fri Jun 10, 2011 16:03

come sempre, grazie, problema risolto!!! :D
Alessio
Growing Hen
 
Posts: 168
Joined: Mon May 02, 2011 14:14

Previous

Return to Sabayon Linux Discussioni Generali

Who is online

Users browsing this forum: No registered users and 3 guests