flash non funge più dopo aggiornamento driver nvidia

Tutto ciò che è pertinente a Sabayon Linux, indipendentemente dall'architettura e dall'ambiente grafico

Moderator: Moderators

flash non funge più dopo aggiornamento driver nvidia

Postby anonimo » Tue May 10, 2011 18:44

Ciao,
ho aggiornato con sulfur i driver nvidia da 260 a 270. Da quando l'ho fatto su opera non mi funziona più flash player, non riesco a vedere nessun tipo di video. Il sistema sembra riconoscere il plugin solo che al posto del video rimane lo schermo nero. Ho provato a reinstallare sia opera che flash che i driver nvidia ma non c'è stato niente da fare. Come mi consigliereste voi di muovermi adesso?


P.S. con firefox flash funge, non so cosa possa essere. Ho provato a copiare il file libflashplayer.so da /usr/lib64/nsbrowser/plugins a /usr/lib64/opera/plugins ma il risultato non cambia. Come posso fare per continuare ad usare opera?

Ciao
User avatar
anonimo
Growing Hen
 
Posts: 108
Joined: Tue Feb 01, 2011 14:00

Re: flash non funge più dopo aggiornamento driver nvidia

Postby Sad » Tue May 17, 2011 9:48

Ho lo stesso problema. Non so che fare le ho provate tutte.
Sad
Baby Hen
 
Posts: 14
Joined: Sun Oct 10, 2010 22:30

Re: flash non funge più dopo aggiornamento driver nvidia

Postby micia » Fri May 20, 2011 21:50

Salve, avete provato a controllare cosa vi dice:
Code: Select all
eselect opengl list

?

Dovrebbe comparirvi una lista delle implementazioni delle OpenGL disponibili, dovreste controllare che il * sia accanto al modello della vostra scheda video (xorg-x11 in caso di intel o comunque di driver open source), quindi nel vostro caso dovrebbe essere accanto a nvidia. Se non lo fosse eseguite:
(come root)
Code: Select all
eselect opengl set nvidia


Ultimamente, tra l'altro, è anche uscito un aggiornamento dei driver.
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: flash non funge più dopo aggiornamento driver nvidia

Postby anonimo » Fri May 20, 2011 22:51

Sì l'avevo già fatto quando ho aggiornato il kernel. E l'ho rifatto pure da poco visto che da poche ore ho reinstallato sabayon con kde(fino a ieri avevo gnome e credo ci tornerò). Io prima avevo risolto downgradando la mia versione di opera con portato. Solo che ora in portage non ho più il pacchetto per ripristinare la versione precedente. C'è un modo per tornare ad una versione di opera non più visibile in portage o in entropy?
User avatar
anonimo
Growing Hen
 
Posts: 108
Joined: Tue Feb 01, 2011 14:00

Re: flash non funge più dopo aggiornamento driver nvidia

Postby micia » Sat May 21, 2011 1:54

Hai provato l'ultimissima versione in portage? La versione di portage è più avanti di quella di entropy, magari ti risolve il problema, nel caso sarebbe l'ideale segnalarlo poi agli sviluppatori per mettere la versione in entropy.

Per installarla devi usare questo procedimento:
(come root)
Code: Select all
emerge --sync
emerge -1av opera

il primo comando sincronizza portage con i pacchetti disponibili, il secondo compila il pacchetto di opera.
Fatto questo esegui:
(come root)
Code: Select all
equo rescue spmsync

per sincronizzare entropy con portage.

Prova se funziona, altrimenti puoi reinstallare la versione di entropy.

Se funzionasse sarebbe bene avvisare gli sviluppatori, in modo che possano mettere la versione nuova in entropy.
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: flash non funge più dopo aggiornamento driver nvidia

Postby anonimo » Sat May 21, 2011 8:22

Ho aggiornato opera all'ultima versione disponibile, ma non ho risolto. Con il comando che mi hai consigliato mi diceva che potevo aggiornare anche flash player e sun jdk development kit. Solo che non potevo andare avanti che i pacchetti erano mascherati
Code: Select all
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] www-client/opera-11.11.2109 [11.10.2092-r1] USE="gstreamer gtk -kde*" LINGUAS="bg* cs* da* de* el* en_GB* es_ES* et* fi* fr fy* hi* hr* hu* it ja* ko* lt* mk* nb* nl* nn* pl* pt* pt_BR ro* ru* sk* sr* sv* ta* tr* uk* vi* zh_CN* zh_TW* -be -es_LA -fr_CA -gd -id -ka -te (-af%) (-az%) (-me%) (-ms%) (-th%) (-tl%) (-uz%)" 10,795 kB

Total: 1 package (1 upgrade), Size of downloads: 10,795 kB

!!! The following installed packages are masked:
- www-plugins/adobe-flash-10.2.153.1_p201011173::gentoo (masked by: AdobeFlash-10.1 license(s))
A copy of the 'AdobeFlash-10.1' license is located at '/usr/portage/licenses/AdobeFlash-10.1'.

- dev-java/sun-jdk-1.6.0.24::gentoo (masked by: dlj-1.1 license(s))
A copy of the 'dlj-1.1' license is located at '/usr/portage/licenses/dlj-1.1'.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Che posso fare?
User avatar
anonimo
Growing Hen
 
Posts: 108
Joined: Tue Feb 01, 2011 14:00

Re: flash non funge più dopo aggiornamento driver nvidia

Postby micia » Sat May 21, 2011 9:52

Quel messaggio è dovuto al fatto che secondo portage non hai ancora accettato le licenze di quei pacchetti, portage ha un metodo abbastanza "rudimentale" per trattare le licenze, non è affatto user friendly quanto entropy :lol:

apri come root il file:
/etc/make.conf
per esempio usa questo comando su KDE4:
Code: Select all
kdesu kwrite /etc/make.conf

o questo su Gnome:
Code: Select all
gksu gedit /etc/make.conf


Dovrebbe esserci una riga del genere:
Code: Select all
#ACCEPT_LICENSE="*"

il # rende la riga un commento, rimuovilo per far diventare la riga come segue:
Code: Select all
ACCEPT_LICENSE="*"

Nel caso tu non avessi una riga #ACCEPT_LICENSE="*" aggiungi semplicemente ACCEPT_LICENSE="*" alla fine del file, in una nuova riga.
La riga che aggiungiamo al file make.conf informa portage che intendiamo accettare qualsiasi licenza, anche non open source, che vincola i pacchetti che andiamo ad installare.

Ad ogni modo, dovrebbe avertela installata comunque l'ultima versione di opera, o no?
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: flash non funge più dopo aggiornamento driver nvidia

Postby Sad » Sat May 21, 2011 13:29

Scusate l'intromissione. Ho seguito tutte le istruzioni di micia ma non è cambiato nulla, neanche con la nuova versione di Opera installata con portage
Sad
Baby Hen
 
Posts: 14
Joined: Sun Oct 10, 2010 22:30

Re: flash non funge più dopo aggiornamento driver nvidia

Postby anonimo » Sat May 21, 2011 13:34

Ho reso installabili i pacchetti con licenza da portage. A quel punto ho provato a emergere opera ma non si segnalava più la presenza di aggiornamenti per flash e sun jdk. A quel punto me li sono installati manualmente con portato. Il risultato purtroppo non cambia: continua a non funzionare :(
User avatar
anonimo
Growing Hen
 
Posts: 108
Joined: Tue Feb 01, 2011 14:00

Re: flash non funge più dopo aggiornamento driver nvidia

Postby micia » Sat May 21, 2011 13:42

Quelli di prima non erano aggiornamenti, era solo una notifica del fatto che avevi installato pacchetti di cui non avevi ancora accettato la licenza.
La cosa strana è che ho installato Opera anche io, per tentare di capire qualcosa di più, flash funziona perfettamente, sono su una piattaforma AMD64.
L'unica differenza è che ho una ATI, però è piuttosto incredibile che funzioni con una versione vecchia di Opera, e sopratutto che funzioni con firefox ma non con Opera, sarei propenso a pensare a un difetto di Opera, ma con me funziona alla perfezione...
Potete farmi un esempio di pagina in cui flash non vi funziona?
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Next

Return to Sabayon Linux Discussioni Generali

Who is online

Users browsing this forum: No registered users and 1 guest

cron