problemino kernel [Risolto]

Tutto ciò che è pertinente a Sabayon Linux, indipendentemente dall'architettura e dall'ambiente grafico

Moderator: Moderators

problemino kernel [Risolto]

Postby lucasaba » Sun Mar 20, 2011 22:55

ho il seguente problemino col kernel....

ho acceso il pc ed e' venuta fuori la solita richiesta di fare l'aggiornamento...cosi' vado su terminale...
dgt
Code: Select all
su
equo upgrade


mentre scarica e installa i vari aggiornamenti....mi accorgo che ha aggiornato il kernel alla versione 2.6.38....
riavvio ma da grub vedo che non e' disponibile la versione 2.6.38.
Ho continuato lanciando la versione 2.6.36....quando il sistema ha caricato lanciando
Code: Select all
uname -r
ovviamente mi dice che il kernel è il il 2.6.36....
se digito
Code: Select all
equo search kernel

mi da tutte le varie possibilità con piccola descrizione e vedo che il kernel 2.6.38 risulta non installato.....
io pero' sono sicurissimo che durante la procedura di aggiortnamento me l'abbia aggiornato....
potete darmi una mano ad uscire da questo piccolo dilemma?

Grazie

Luca
Last edited by lucasaba on Mon Mar 21, 2011 21:10, edited 1 time in total.
lucasaba
Advanced Hen
 
Posts: 222
Joined: Sun Mar 08, 2009 20:09

Re: problemino kernel

Postby micia » Sun Mar 20, 2011 23:38

Ciao,
che io sappia, entropy non aggiorna mai un kernel automaticamente, è richiesto che l'utente ordini esplicitamente l'aggiornamento con equo install o col nuovo fiammante kernel-switcher 8)
Sicuro di non esserti confuso con equo update che ha fatto vedere l'iniezione del pacchetto contenente il nuovo kernel?

Nel caso volessi essere sicuro, prova a controllare di non avere pacchetti installati per quella versione del kernel:
Code: Select all
equo query installed "#2.6.38-sabayon"
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: problemino kernel

Postby lucasaba » Mon Mar 21, 2011 19:19

digitando come da te suggerito
Code: Select all
equo query installed "#2.6.38-sabayon"

l'output e' il seguente
Code: Select all
equo query installed "#2.6.38-sabayon"
>>  @@ Cercando...
>>  Keyword:  #2.6.38-sabayon
>>  Trovati:  0 voci


ma non e' normale che sia cosi'? nel senso io da grub faccio gia' partire il 2.6.36 (come gia' detto del 2.6.38 non c'e' traccia) quindi probabilmente lui vede come installato il 2.6.36.....

Tornando al discorso dell'installazione credo di avere installato il 2.6.38 perche' ho lanciato equo upgrade (e non UPDATE)....e di solito con equo upgrade aggiorni i pacchetti installati....tan't' che dopo l'operazione non ho ricevuto altri messaggi di richiesta di aggiornamento.....

che dici micia? mi dai qualche suggerimento?
lucasaba
Advanced Hen
 
Posts: 222
Joined: Sun Mar 08, 2009 20:09

Re: problemino kernel

Postby micia » Mon Mar 21, 2011 20:16

No, non è normale che ti abbia installato il kernel 2.6.38 con un semplice equo upgrade, dato che, come dici, aggiorna i pacchetti installati, ma il kernel è considerato un pacchetto particolarmente rilevante. Per cui è richiesto che venga aggiornato esplicitamente, non venendo tirato in ballo da un aggiornamento generale, solo perché ne esiste una versione più recente.
Altrimenti dovresti avere installato anche il 2.6.37, mentre mi pare che tu abbia solo il 2.6.36.
Il fatto che da GRUB e nel database di entropy non ve ne sia traccia conferma la mia tesi, sei sicuro di non esserti confuso?
Puoi controllare anche i log di entropy contenuti in:
/var/log/entropy
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: problemino kernel

Postby lucasaba » Mon Mar 21, 2011 20:26

come da te suggerito guardando il log.....


Code: Select all
[21:34:04 20/03/2011 CET] INFO: [Package] [client] Unpacking package: sys-kernel/linux-firmwares-2.6.38
[21:34:04 20/03/2011 CET] INFO: [Portage setup] [spm]
 * Package:    sys-kernel/linux-firmwares-2.6.38
 * Repository: sabayon
 * USE:        amd64 elibc_glibc kernel_linux multilib userland_GNU
 * FEATURES:   preserve-libs sandbox

[21:34:04 20/03/2011 CET] INFO: [Portage setup] [spm]
 * Package:    sys-kernel/linux-firmwares-2.6.38
 * Repository: sabayon
 * USE:        amd64 elibc_glibc kernel_linux multilib userland_GNU
 * FEATURES:   preserve-libs sandbox

[21:34:05 20/03/2011 CET] INFO: [Package] [client] Installing package: sys-kernel/linux-firmwares-2.6.38
[21:34:07 20/03/2011 CET] INFO: [Package] [client] Remove old package (spm data): sys-kernel/linux-firmwares-2.6.37
[21:34:07 20/03/2011 CET] INFO: [Package] [client] Removing from SPM: sys-kernel/linux-firmwares-2.6.37
[21:34:07 20/03/2011 CET] INFO: [Package] [client] Installing new SPM entry: sys-kernel/linux-firmwares-2.6.38
[21:34:07 20/03/2011 CET] INFO: [Trigger] [client] [POST] Running env_update
[21:34:09 20/03/2011 CET] INFO: [Package] [client] Unpacking package: kde-misc/magneto-kde-1.0_alpha32
[21:34:09 20/03/2011 CET] INFO: [Package] [client] Installing package: kde-misc/magneto-kde-1.0_alpha32
[21:34:10 20/03/2011 CET] INFO: [Package] [client] Remove old package (spm data): kde-misc/magneto-kde-1.0_alpha30
[21:34:10 20/03/2011 CET] INFO: [Package] [client] Removing from SPM: kde-misc/magneto-kde-1.0_alpha30
[21:34:10 20/03/2011 CET] INFO: [Package] [client] Installing new SPM entry: kde-misc/magneto-kde-1.0_alpha32
[21:34:10 20/03/2011 CET] INFO: [Trigger] [client] [POST] Running env_update
[21:34:11 20/03/2011 CET] INFO: [Portage setup] [spm]
 * Package:    kde-misc/magneto-kde-1.0_alpha32
 * Repository: sabayon
 * USE:        amd64 elibc_glibc kernel_linux multilib userland_GNU
 * FEATURES:   preserve-libs sandbox
lucasaba
Advanced Hen
 
Posts: 222
Joined: Sun Mar 08, 2009 20:09

Re: problemino kernel

Postby micia » Mon Mar 21, 2011 20:31

quello è il pacchetto linux-firmwares, non è il kernel. Non son sicuro del perché, nonostante abbia una versione uguale al kernel, venga aggiornato anche se il tuo kernel è più vecchio, non son un esperto in questo campo, quel che è sicuro è che non è il kernel (che è, invece, il pacchetto linux-sabayon).
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: problemino kernel

Postby lucasaba » Mon Mar 21, 2011 20:33

ok svelato l'arcano....grazie mille.....

un''ultima domanda...
ma se io scrivo equo install kernel 2.6.38
fa tutto da solo....o devo riconfigurare il grub?

in poche parole per aggiornare il kernel?
lucasaba
Advanced Hen
 
Posts: 222
Joined: Sun Mar 08, 2009 20:09

Re: problemino kernel

Postby micia » Mon Mar 21, 2011 20:40

Se vuoi usare manualmente equo devi manualmente aggiornare tutti i moduli, l'aggiornamento del kernel è una procedura delicata e che merita molta attenzione. È proprio per questo che entropy non la fa automaticamente.
Il menu di GRUB, invece, viene aggiornato automaticamente all'atto dell'installazione del pacchetto del nuovo kernel.
Se vuoi una procedura automatizzata prova kernel-switcher:
Code: Select all
kernel-switcher --help

ti mostrerà come usarlo.
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: problemino kernel

Postby lucasaba » Mon Mar 21, 2011 21:10

funziona lo switcher
lucasaba
Advanced Hen
 
Posts: 222
Joined: Sun Mar 08, 2009 20:09


Return to Sabayon Linux Discussioni Generali

Who is online

Users browsing this forum: No registered users and 1 guest

cron