ho urgente bisogno di libc.so.6 + librt.so.1

Tutto ciò che è pertinente a Sabayon Linux, indipendentemente dall'architettura e dall'ambiente grafico

Moderator: Moderators

ho urgente bisogno di libc.so.6 + librt.so.1

Postby ptomma62 » Mon Nov 06, 2006 10:46

come dicevo sopra ho bisogno di queste librerie per far funzionare cmapstools, un programma per le mappe mentali, come posso fare per averle? :shock:
ho provato a scrivere: "emerge nome" ma non ha funzionato. alternativamente ho provato a cercarli in internet, ma ho solo trovato roba in inglese (che non conosco) e sempre roba che appartiene a debian o mandrake o altri ma non a gentoo. .. si lo so sono un po imbranato con i computer, .. sempre meglio che usare winzozz :oops:
mi date una mano? purtroppo il programma mi serve per lavoro e fintanto che non riesco a farlo funzionare.... non posso lavorare... help me! :wink: aiutoo...
ptomma62
Baby Hen
 
Posts: 18
Joined: Sun Nov 05, 2006 14:11

Postby cr7 » Tue Nov 07, 2006 17:20

Hai usato "emerge --sync" per scaricare il database dei pacchetti? :D
cr7
Baby Hen
 
Posts: 12
Joined: Tue Nov 07, 2006 16:35

Postby ptomma62 » Tue Nov 07, 2006 23:59

si l'ho usato, mi ha dato una supermega lista di roba, ma poi? non essendo un provetto linuxiano ho provato a dare emerge libc.so.6 ma mi ha dato un not found o roba simile, lo stesso dicasi per librt.so.1. non so da che parte girarmi...
..non so se sto dicendo cavolate, ma dovrei scaricare qualcos'altro? mi hanno detto di installare le glibc e l'ho fatto (mezz'ora) sempre con emerge, ma non è cambiato nulla.
cos'altro posso fare?
ptomma62
Baby Hen
 
Posts: 18
Joined: Sun Nov 05, 2006 14:11

Postby lxnay » Wed Nov 08, 2006 0:30

Prima di tutto dovresti dirmi che versione di SL hai, se la x86 o la x86-64. libc.so.6 fa parte di qualsiasi versione di SL. E poi, non ho capito cosa stai cercando di fare... usare un rpm per caso? Insomma, dovresti essere più chiaro se vuoi che ti aiutiamo.

Code: Select all
phobos ~ # /lib/libc.so.6
GNU C Library stable release version 2.5, by Roland McGrath et al.
Copyright (C) 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.
There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A
PARTICULAR PURPOSE.
Compiled by GNU CC version 4.1.1 (Gentoo 4.1.1-r1).
Compiled on a Linux 2.6.17 system on 2006-10-17.
Available extensions:
        The C stubs add-on version 2.1.2.
        crypt add-on version 2.1 by Michael Glad and others
        GNU Libidn by Simon Josefsson
        GNU libio by Per Bothner
        NIS(YP)/NIS+ NSS modules 0.19 by Thorsten Kukuk
        Native POSIX Threads Library by Ulrich Drepper et al
        Support for some architectures added on, not maintained in glibc core.
        BIND-8.2.3-T5B
Thread-local storage support included.
For bug reporting instructions, please see:
<http://www.gnu.org/software/libc/bugs.html>.
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3596
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Postby ptomma62 » Wed Nov 08, 2006 8:48

hai ragione! uso l'ultima venuta fuori trovata sulla rivista linux pro su un x86, no non è un rpm ma un file compresso aueseguibile con Sh per il programma di Cmaptools (serve per fare le mappe mentali e concettuali) ed è un programma che ti permette di condividere le mappe con gli altri... in soldoni per me è un programma necessario. ..solo all'idea di reinsttallare il winzoz sto male...
una volta installato il programma tutto ok, ma al momento del via niente, facendolo da riga di comando vengono fuori queste righe:
# sh CmapTools
dirname: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
/bin/ls: error while loading shared libraries: librt.so.1: cannot open shared object file: No such file or directory
basename: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
dirname: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
basename: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
rm: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

cheddici, si può curare?
uso kde 3.5.4
nel post precedente come hai fatto a far venir fuori quella schermata?
Last edited by ptomma62 on Wed Nov 08, 2006 9:22, edited 1 time in total.
ptomma62
Baby Hen
 
Posts: 18
Joined: Sun Nov 05, 2006 14:11

Postby ptomma62 » Wed Nov 08, 2006 9:00

mi stavo scordando.. il programma di cmaps lo trovi qui, http://cmap.ihmc.us (io uso google per la traduzione.. altrimenti non capisco nulla. ciao ciao :wink:
ptomma62
Baby Hen
 
Posts: 18
Joined: Sun Nov 05, 2006 14:11

Postby GattoTigre » Wed Nov 08, 2006 21:22

2 sere fà ho visto il post e ho controllato sul mio server; io non ho il file ma un link simbolico da libc.so.4.

ho fatto una ricerca e (ho compreso che) quella libreria è compresa in glibc-2.5. Penso che per aggiornalo/installarlo la sintassi da Shell dovrebbe essere:

Code: Select all
emerge --sync (se non lo hai fatto nelle ultime 24 ore)

emerge sys-libs/glibc-2.5 [2.4-r3] USE="-glibc-compat20%"


tieni presente che alcuni requisiti NON li stai soddisfando - specialmente il fatto che non hai RH:

http://cmap.ihmc.us/download/index.php?myPlat=Linux

magari non importa - magari sì.
GattoTigre
Baby Hen
 
Posts: 9
Joined: Wed Nov 01, 2006 11:29

Postby ptomma62 » Thu Nov 09, 2006 8:28

l'ho fatta "volare" su mandriva, su qilinux, su knoppix ha sempre funzionato...
le Glibc le ho già installate... ma nulla.
ho provato a rifare anche l'installazione, ma niente...
hai detto che non hai il file ma un link simbolico, e se ho capito bene è un collegamento simbolico con un file, ma come fai a fare un collegamento senza il file? ..magari è una domanda idiota, ma è da poco tempo che sto cercando di "imparare" linux.. :-)
Vorrà dire che mi installerò una seconda distribuzione sul secondo hd... ma non mi piace, sono riuscito ad eliminare winzoz e il problema di cmaptools è l'unico che mi è rimasto, tutto "trasbordato" in linux... :twisted: :twisted: :twisted: :twisted: :twisted:
vabbhe... ma non mi arrendo! a costo di incasinare o reinstallare tutto per l'ennesima volta.....
ciao ciao
ptomma62
Baby Hen
 
Posts: 18
Joined: Sun Nov 05, 2006 14:11

Postby GattoTigre » Thu Nov 09, 2006 21:09

per i link simbolici ti rimando a questo sito: http://www.univ.trieste.it/csia/doc/old ... 2.9.1.html

quello che io ho dentro a libc.so.6 è

libc.so.6: symbolic link to 'libc-2.4.so'

fai bene a non mollare.

Sono nella tua medesima condizione anzi mi sà che Linuxicamente parlando sono messo molto "peggio". Però ho esperienza con altri SistemiOperativi ed essendo (per lavoro) abituato ai debug per un errore come questo

dirname: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

avrei fatto:
1. copia incolla in Google
2. davo un'occhiata ai post simili
3. controllavo le variabili di sistema ( ENV ) etc
GattoTigre
Baby Hen
 
Posts: 9
Joined: Wed Nov 01, 2006 11:29


Return to Sabayon Linux Discussioni Generali

Who is online

Users browsing this forum: No registered users and 1 guest