problema scheda audio

Tutto ciò che è pertinente a Sabayon Linux, indipendentemente dall'architettura e dall'ambiente grafico

Moderator: Moderators

Postby ajez » Thu Nov 23, 2006 19:20

erotanes wrote:Salve a tutti!

Anch'io posseggo un asus serie askm ed ho problemi con la sk audio :(

Dunque per risolvere il problema dovrei ricompilare il kernel?

Per favore qualcuno mi spiega esattamente quali parametri settare nel nuovo kernel?

grazie!


bè, prima dicci che problema hai :P
ajez
The Blamed One
 
Posts: 506
Joined: Mon Oct 16, 2006 17:17
Location: Venezia - /dev/null

Postby erotanes » Thu Nov 23, 2006 23:55

Il problema è che semplicemente,la mia linux box è muta ho provato con alsaconf, ma niente!
Ho pensato di scrivere visto che ho letto che c'è qualcun'altro che ha avuto problemi con la sk audio dell'asus a6km(che dovrebbe essere: Silicon Integrated Systems [SiS] AC'97 Sound Controller).
Spero possiate aiutarmi!
grazie!
erotanes
Young Hen
 
Posts: 23
Joined: Thu Nov 23, 2006 18:08

Postby ajez » Fri Nov 24, 2006 9:40

erotanes wrote:Il problema è che semplicemente,la mia linux box è muta ho provato con alsaconf, ma niente!
Ho pensato di scrivere visto che ho letto che c'è qualcun'altro che ha avuto problemi con la sk audio dell'asus a6km(che dovrebbe essere: Silicon Integrated Systems [SiS] AC'97 Sound Controller).
Spero possiate aiutarmi!
grazie!


hai provato a vedere se per caso il volume è muto? perché alcuni hanno avuto sto problema, che la scheda andava ma era stata "mutata" e nn sentivano niente :D
ajez
The Blamed One
 
Posts: 506
Joined: Mon Oct 16, 2006 17:17
Location: Venezia - /dev/null

Postby erotanes » Fri Nov 24, 2006 17:45

Il volume sembra ok! ho verificato con alsamixer. Quando lancio xmms per riprodurre un file audio sembra tutto ok... solo che non sento niente!!! :cry:
erotanes
Young Hen
 
Posts: 23
Joined: Thu Nov 23, 2006 18:08

Postby ajez » Fri Nov 24, 2006 17:51

erotanes wrote:Il volume sembra ok! ho verificato con alsamixer. Quando lancio xmms per riprodurre un file audio sembra tutto ok... solo che non sento niente!!! :cry:


:shock:

hai guardato su kmixer?
ajez
The Blamed One
 
Posts: 506
Joined: Mon Oct 16, 2006 17:17
Location: Venezia - /dev/null

Postby erotanes » Fri Nov 24, 2006 18:02

allora lancio kmix ed ecco il risultato:

le uscite sono tutte OK ed ho attivato pure tutti gli interruttori
erotanes
Young Hen
 
Posts: 23
Joined: Thu Nov 23, 2006 18:08

Postby erotanes » Fri Nov 24, 2006 19:36

ho fatto un pò di ricerche ed ho trovato questo:

Scheda audio (Silicon Integrated Systems [SiS] AC'97 Sound Controller)

Al momento c'è un noto bug nel driver alsa, quindi per far funzionare correttamente la scheda è necessario:

* compilate il kernel senza Supporto ALSA (solo SOUND CARD SUPPORT)
* aggiungete la use flag debug nel pacchetto media-sound/alsa-driver e poi emergete il driver

# echo "media-sound/alsa-driver debug" >> /etc/portage/package.use
# emerge -av alsa-driver

* aggiungete la riga echo "7a 57c1" > /proc/asound/card0/codec97#0/ac97#0-0+regs al file /etc/conf.d/local.start, permettendo di eseguire il commando ad ogni riavvio (serve per configurare correttamente dei registri del driver..nn chiedetemi altro ;))

# echo 'echo "7a 57c1" > /proc/asound/card0/codec97#0/ac97#0-0+regs' >> /etc/conf.d/local.start

* Se volete far funzionare la scheda immediatamente e non al prossimo riavvio eseguite anche il commando

# echo "7a 57c1" > /proc/asound/card0/codec97#0/ac97#0-0+regs

Ora la vostra scheda audio dovrebbe funzionare a dovere ;)



bene!
Nuovi problemi!
lancio:
# emerge -av alsa-driver
ed ottengo:
configure: error: You have built-in ALSA in your kernel.

!!! Please attach the following file when filing a report to bugs.gentoo.org:
!!! /var/tmp/portage/media-sound/alsa-driver-1.0.13/work/alsa-driver-1.0.13/config.log

!!! ERROR: media-sound/alsa-driver-1.0.13 failed.
Call stack:
ebuild.sh, line 1568: Called dyn_compile
ebuild.sh, line 937: Called src_compile
alsa-driver-1.0.13.ebuild, line 99: Called econf '--without-oss' '--with-debug=full' '--with-kernel=/usr/src/linux' '--with-build=/usr/src/linux' '--with-isapnp=yes' '--with-sequencer=yes' '--with-cards=all'
ebuild.sh, line 540: Called die

!!! econf failed
!!! If you need support, post the topmost build error, and the call stack if relevant.
erotanes
Young Hen
 
Posts: 23
Joined: Thu Nov 23, 2006 18:08

Postby ajez » Fri Nov 24, 2006 19:48

erotanes wrote:[cut]
* compilate il kernel senza Supporto ALSA (solo SOUND CARD SUPPORT)
* aggiungete la use flag debug nel pacchetto media-sound/alsa-driver e poi emergete il driver

# echo "media-sound/alsa-driver debug" >> /etc/portage/package.use
# emerge -av alsa-driver
[cut]



hai ricompilato il kernel? sai come si fà? se no, guarda che nn è facilissimo ..
ajez
The Blamed One
 
Posts: 506
Joined: Mon Oct 16, 2006 17:17
Location: Venezia - /dev/null

Postby erotanes » Fri Nov 24, 2006 20:07

Si ho ricompilato. Con Slackware lo facevo spesso e non avevo problemi. Qualche problema l'ho avuto per far partire il nuovo kernel perchè non conosco bene GRUB... a proposito... qualcuno mi dice sos'è: initrd /boot/initramfs-genkernel-x86-2.6.17-gentoo-r7 nel file grub.conf? In pratica per far partire il nuovo kernel che si chiama 2.6.17-gentoo-r7-raf, ho copiato initrd /boot/initramfs-genkernel-x86-2.6.17-gentoo-r7 del vecchio kernel.
erotanes
Young Hen
 
Posts: 23
Joined: Thu Nov 23, 2006 18:08

Postby ajez » Fri Nov 24, 2006 21:14

nella sezione howto dovrebbe esserci una guida per fare la compilazione con genkernel, che è un comando apposito per gentoo .. infatti ricompilando il kernel (togliendo alsa) devi anche creare una initrd nuova .. cmq, se segui la guida, genkernel si arrangia a fare tutto (tranne a togliere alsa dalla conf del kernel :D )
ajez
The Blamed One
 
Posts: 506
Joined: Mon Oct 16, 2006 17:17
Location: Venezia - /dev/null

PreviousNext

Return to Sabayon Linux Discussioni Generali

Who is online

Users browsing this forum: No registered users and 1 guest