aggiornare freepops

Tutto ciò che è pertinente a Sabayon Linux, indipendentemente dall'architettura e dall'ambiente grafico

Moderator: Moderators

crisandbea
Old Dear Hen
Posts: 651
Joined: Tue Feb 12, 2008 11:36
Location: Bosco(SA)

Re: aggiornare freepops

Post by crisandbea » Sun Dec 07, 2008 19:45

dallo sempre senza USE="-deprecated" xchè in quella versione di freepops richiede quelle librerie con quella flag.

ciauz

belcocco
Old Dear Hen
Posts: 459
Joined: Sat Nov 29, 2008 18:53
Location: Milan, Italy

Re: aggiornare freepops

Post by belcocco » Sun Dec 07, 2008 20:06

....con 'deprecated' o senza il risultato è sempre:

>>> Failed to install dev-lang/lua-5.1.4, Log file:
>>> '/var/lib/entropy/logs/dev-lang:lua-5.1.4:20081207-195027.log'


...Boh....cmq grazie.
Belcocco

crisandbea
Old Dear Hen
Posts: 651
Joined: Tue Feb 12, 2008 11:36
Location: Bosco(SA)

Re: aggiornare freepops

Post by crisandbea » Sun Dec 07, 2008 21:17

belcocco wrote:....con 'deprecated' o senza il risultato è sempre:

>>> Failed to install dev-lang/lua-5.1.4, Log file:
>>> '/var/lib/entropy/logs/dev-lang:lua-5.1.4:20081207-195027.log'


...Boh....cmq grazie.
Belcocco
è importante avere l'errore completo e preciso non solo parti prese cosi....

belcocco
Old Dear Hen
Posts: 459
Joined: Sat Nov 29, 2008 18:53
Location: Milan, Italy

Re: aggiornare freepops

Post by belcocco » Sun Dec 07, 2008 23:53

Hai ragione crisandbea.....ma ti assicuro che gli errori sono uguali a quanto ho già postato, cioè il fatto di inserire USE="-deprecated" o meno nel commando emerge -av freepops non ha fatto cambiare i risultati dei log e degli output a console.
Anche il comando libtool --finish //usr/lib/ non è servito.
Ormai le ho provate tutte....chissà dov'è l'inghippo.
Capisco che ci debba essere per forza una soluzione, ma gli elementi che sono emersi sono pochi e si deve proseguire secondo me per tentativi.

Per esempio, non è che bisogna aggiornare il kernel?
Forse bisogna aspettare la versione 4.0 di sabayon? Posso anche aspettare se fosse quello.
C'è qlc che ha installato freepops 0.2.8 e riesce a scaricare da hotmail ???
Cosa ne pensate?

Grazie per ogni info
Ciao
Belcocco

red.hell
Old Dear Hen
Posts: 862
Joined: Tue Jul 24, 2007 14:38

Re: aggiornare freepops

Post by red.hell » Mon Dec 08, 2008 10:42

hai provato a dare prima un

Code: Select all

equo remove lua
e poi installarlo da portage con

Code: Select all

emerge lua
?

crisandbea
Old Dear Hen
Posts: 651
Joined: Tue Feb 12, 2008 11:36
Location: Bosco(SA)

Re: aggiornare freepops

Post by crisandbea » Mon Dec 08, 2008 11:43

belcocco wrote:Hai ragione crisandbea.....ma ti assicuro che gli errori sono uguali a quanto ho già postato, cioè il fatto di inserire USE="-deprecated" o meno nel commando emerge -av freepops non ha fatto cambiare i risultati dei log e degli output a console.
Anche il comando libtool --finish //usr/lib/ non è servito.
Ormai le ho provate tutte....chissà dov'è l'inghippo.
Capisco che ci debba essere per forza una soluzione, ma gli elementi che sono emersi sono pochi e si deve proseguire secondo me per tentativi.

Per esempio, non è che bisogna aggiornare il kernel?
Forse bisogna aspettare la versione 4.0 di sabayon? Posso anche aspettare se fosse quello.
C'è qlc che ha installato freepops 0.2.8 e riesce a scaricare da hotmail ???
Cosa ne pensate?

Grazie per ogni info
Ciao
Belcocco
prova a dare

Code: Select all

 emerge --sync; layman -s sabayon; emerge -av freepops
ciauz

belcocco
Old Dear Hen
Posts: 459
Joined: Sat Nov 29, 2008 18:53
Location: Milan, Italy

Re: aggiornare freepops

Post by belcocco » Mon Dec 08, 2008 12:05

red.hell wrote:hai provato a dare prima un

Code: Select all

equo remove lua
e poi installarlo da portage con

Code: Select all

emerge lua
?
Grazie per la dritta red.hell :D , ho fatto un passo in avanti, anche se non ho risolto.

Con il comando 'equo remove lua' sono riuscito a disinstallare il lua 5.1.3 e con il comando 'emerge lua' ho installato il lua 5,1,4 che è la dipendenza richiesta da freepops 0.2.8.
Infatti se do 'emerge --search lua' adesso ottengo:
* dev-lang/lua
Latest version available: 5.1.4
Latest version installed: 5.1.4
Size of files: 211 kB
Homepage: http://www.lua.org/
Description: A powerful light-weight programming language designed for extending applications
License: MIT

quindi il lua è installato. :)

Però .....e sì c'è il però, se do a seguire 'emerge --ask freepops' non si comporta come prima che vuole installare il lua prima del pacchetto freepops stesso, ma installa freepops direttamente (giustamente, il lua è già installato) ma dopo la compilazione se ne esce con:

............<omissis>..................(ecc.ecc.che non servono)
building smartlog_lua
building freepopsd
compiling luabox.c -> luabox.o
linking freepopsd

cp: impossibile fare stat di `doc/manual*.pdf': No such file or directory
>>> Completed installing freepops-0.2.8 into /var/tmp/portage/net-mail/freepops-0.2.8/image/

strip: i586-pc-linux-gnu-strip --strip-unneeded -R .comment
usr/bin/freepopsd
ecompressdir: bzip2 -9 /usr/share/man

>>> Installing net-mail/freepops-0.2.8
* This package will overwrite one or more files that may belong to other
* packages (see list below). You can use a command such as `portageq
* owners / <filename>` to identify the installed package that owns a
* file. If portageq reports that only one package owns a file then do
* NOT file a bug report. A bug report is only useful if it identifies at
* least two or more packages that are known to install the same file(s).
* If a collision occurs and you can not explain where the file came from
* then you should simply ignore the collision since there is not enough
* information to determine if a real problem exists. Please do NOT file
* a bug report at http://bugs.gentoo.org unless you report exactly which
* two packages install the same file(s). Once again, please do NOT file
* a bug report unless you have completely understood the above message.
*
* package net-mail/freepops-0.2.8 NOT merged
*
* Detected file collision(s):
*
* /usr/share/doc/freepops-0.2.8/README.bz2
* /usr/share/doc/freepops-0.2.8/ChangeLog.bz2
* /usr/share/doc/freepops-0.2.8/TODO.bz2
* /usr/share/doc/freepops-0.2.8/AUTHORS.bz2
* /usr/share/doc/freepops-0.2.8/MANUAL.txt
* /usr/share/freepops/lua/wel.lua
* /usr/share/freepops/lua/smartlog.lua
*
* Searching all installed packages for file collisions...
*
* Press Ctrl-C to Stop
*
* None of the installed packages claim the file(s).
*
* Package 'net-mail/freepops-0.2.8' NOT merged due to file collisions.
* If necessary, refer to your elog messages for the whole content of the
* above message.

>>> Failed to install net-mail/freepops-0.2.8, Log file:

>>> '/var/lib/entropy/logs/net-mail:freepops-0.2.8:20081208-113429.log'

Credo che il vero problema ora sia questo:
cp: impossibile fare stat di `doc/manual*.pdf': No such file or directory

Avete idee in merito???
Grazie
Ciao
Belcocco

PS. Ho installato thunderbird. Come faccio a installare la funzionalità 'webmail'????

crisandbea
Old Dear Hen
Posts: 651
Joined: Tue Feb 12, 2008 11:36
Location: Bosco(SA)

Re: aggiornare freepops

Post by crisandbea » Mon Dec 08, 2008 12:18

hai dato il comando che ti ho suggerito il post precedente ????

belcocco
Old Dear Hen
Posts: 459
Joined: Sat Nov 29, 2008 18:53
Location: Milan, Italy

Re: aggiornare freepops

Post by belcocco » Mon Dec 08, 2008 14:27

crisandbea wrote:hai dato il comando che ti ho suggerito il post precedente ????
Se ti riferisci a questo: emerge --sync; layman -s sabayon; emerge -av freepops
......certo che l'ho dato, ma il risultato dell'installazione del pacchetto, dopo la sincronizzazione, è:

>>> Installing net-mail/freepops-0.2.8
* checking 68 files for package collisions
* This package will overwrite one or more files that may belong to other
* packages (see list below). You can use a command such as `portageq
* owners / <filename>` to identify the installed package that owns a
* file. If portageq reports that only one package owns a file then do
* NOT file a bug report. A bug report is only useful if it identifies at
* least two or more packages that are known to install the same file(s).
* If a collision occurs and you can not explain where the file came from
* then you should simply ignore the collision since there is not enough
* information to determine if a real problem exists. Please do NOT file
* a bug report at http://bugs.gentoo.org unless you report exactly which
* two packages install the same file(s). Once again, please do NOT file
* a bug report unless you have completely understood the above message.
*
* package net-mail/freepops-0.2.8 NOT merged
*
* Detected file collision(s):
*
* /usr/share/doc/freepops-0.2.8/README.bz2
* /usr/share/doc/freepops-0.2.8/ChangeLog.bz2
* /usr/share/doc/freepops-0.2.8/TODO.bz2
* /usr/share/doc/freepops-0.2.8/AUTHORS.bz2
* /usr/share/doc/freepops-0.2.8/MANUAL.txt
* /usr/share/freepops/lua/wel.lua
* /usr/share/freepops/lua/smartlog.lua
*
* Searching all installed packages for file collisions...
*
* Press Ctrl-C to Stop
*
* None of the installed packages claim the file(s).
*
* Package 'net-mail/freepops-0.2.8' NOT merged due to file collisions.
* If necessary, refer to your elog messages for the whole content of the
* above message.

>>> Failed to install net-mail/freepops-0.2.8, Log file:

>>> '/var/lib/entropy/logs/net-mail:freepops-0.2.8:20081208-141158.log'


e il file di log è:

extensa belcocco # cat /var/lib/entropy/logs/net-mail:freepops-0.2.8:20081208-141158.log
>>> Unpacking source...
>>> Unpacking freepops-0.2.8.tar.gz to /var/tmp/portage/net-mail/freepops-0.2.8/work
>>> Source unpacked.
* Applying freepops-0.2.3-pop3config.diff ... [ ok ]
>>> Configuring source in /var/tmp/portage/net-mail/freepops-0.2.8/work/freepops-0.2.8 ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/net-mail/freepops-0.2.8/work/freepops-0.2.8 ...
make -j2 -s -j1 H= all
building luasocket
building luasocket... done.
building luay
building dep for luay.c
compiling luay.c -> luay.o
linking libluay.a
building luabind
building dep for luabind.c
compiling luabind.c -> luabind.o
linking libluabind.a
building oscompatibility
building dep for win32_compatibility.c
building dep for c99_compatibility.c
building dep for beos_compatibility.c
compiling beos_compatibility.c -> beos_compatibility.o
compiling c99_compatibility.c -> c99_compatibility.o
compiling win32_compatibility.c -> win32_compatibility.o
linking liboscompatibility.a
building regularexp
building dep for regularexp.c
compiling regularexp.c -> regularexp.o
linking libregularexp.a
building log
building dep for log.c
compiling log.c -> log.o
linking liblog.a
building base64
building dep for base64.c
compiling base64.c -> base64.o
linking libbase64.a
building list
building dep for list.c
compiling list.c -> list.o
linking liblist.a
building mlex
building dep for mlex.c
compiling mlex.c -> mlex.o
linking libmlex.a
building pid
building dep for pid.c
compiling pid.c -> pid.o
linking libpid.a
building lock
building dep for lock.c
compiling lock.c -> lock.o
linking liblock.a
building dictionary
building dep for dictionary.c
compiling dictionary.c -> dictionary.o
linking libdictionary.a
building stats_lua
building dep for stats_lua.c
compiling stats_lua.c -> stats_lua.o
linking libstats_lua.a
building session
building dep for session.c
compiling session.c -> session.o
linking libsession.a
building portablesocket
building dep for socketcommon.c
building dep for altsocklib.c
compiling altsocklib.c -> altsocklib.o
compiling socketcommon.c -> socketcommon.o
linking libportablesocket.a
building pop3server
building dep for threads.c
building dep for popstate.c
building dep for popserver.c
compiling popserver.c -> popserver.o
compiling popstate.c -> popstate.o
compiling threads.c -> threads.o
linking libpop3server.a
building pop3server_lua
building dep for pop3server_lua.c
compiling pop3server_lua.c -> pop3server_lua.o
linking libpop3server_lua.a
building session_lua
building dep for session_lua.c
compiling session_lua.c -> session_lua.o
linking libsession_lua.a
building serialize_lua
building log_lua
building dep for log_lua.c
compiling log_lua.c -> log_lua.o
linking liblog_lua.a
building mlex_lua
building dep for mlex_lua.c
compiling mlex_lua.c -> mlex_lua.o
linking libmlex_lua.a
building support_lua
building getdate
compiling getdate.y -> getdate.o
linking libgetdate.a
building getdate_lua
building dep for getdate_lua.c
compiling getdate_lua.c -> getdate_lua.o
linking libgetdate_lua.a
building luacurl
compiling lua-curl.c -> lua-curl.o
linking libluacurl.a
building browser_lua
building stringhack_lua
building dep for stringhack_lua.c
building dep for lstringhack.c
compiling lstringhack.c -> lstringhack.o
compiling stringhack_lua.c -> stringhack_lua.o
linking libstringhack_lua.a
building portablesocket_lua
building base64_lua
building dep for base64_lua.c
compiling base64_lua.c -> base64_lua.o
linking libbase64_lua.a
building mimer_lua
building commonimpl_lua
building regularexp_lua
building dep for regularexp_lua.c
compiling regularexp_lua.c -> regularexp_lua.o
linking libregularexp_lua.a
building luaexpat
compiling lxplib.c -> lxplib.o
linking libluaexpat.a
building xmltables_lua
building httpmail_lua
building crypto_lua
building dep for crypto_lua.c
compiling crypto_lua.c -> crypto_lua.o
linking libcrypto_lua.a
building luafilesystem
compiling lfs.c -> lfs.o
linking libluafilesystem.a
building plugins2xml_lua
building version_comparer_lua
building updater_lua
building xml2tex_lua
building luasoap
building dpipe_lua
building dep for dpipe_lua.c
compiling dpipe_lua.c -> dpipe_lua.o
linking libdpipe_lua.a
building lwel
building lwel.a... done.
building lgettext
building dep for lgettext.c
compiling lgettext.c -> lgettext.o
linking liblgettext.a
building smartlog_lua
building freepopsd
building dep for luabox.c
building dep for freepops.c
building dep for engine.c
compiling engine.c -> engine.o
compiling freepops.c -> freepops.o
compiling luabox.c -> luabox.o
linking freepopsd

>>> Source compiled.
>>> Test phase [not enabled]: net-mail/freepops-0.2.8

>>> Install freepops-0.2.8 into /var/tmp/portage/net-mail/freepops-0.2.8/image/ category net-mail
make -j2 -s -j1 install DESTDIR=/var/tmp/portage/net-mail/freepops-0.2.8/image/
building luasocket
building luay
building luabind
building oscompatibility
building regularexp
building log
building base64
building list
building mlex
building pid
building lock
building dictionary
building stats_lua
building session
building portablesocket
building pop3server
building pop3server_lua
building session_lua
building serialize_lua
building log_lua
building mlex_lua
building support_lua
building getdate
building getdate_lua
building luacurl
building browser_lua
building stringhack_lua
building portablesocket_lua
building base64_lua
building mimer_lua
building commonimpl_lua
building regularexp_lua
building luaexpat
building xmltables_lua
building httpmail_lua
building crypto_lua
building luafilesystem
building plugins2xml_lua
building version_comparer_lua
building updater_lua
building xml2tex_lua
building luasoap
building dpipe_lua
building lwel
building lwel.a... done.
building lgettext
building smartlog_lua
building freepopsd
compiling luabox.c -> luabox.o
linking freepopsd

cp: impossibile fare stat di `doc/manual*.pdf': No such file or directory
>>> Completed installing freepops-0.2.8 into /var/tmp/portage/net-mail/freepops-0.2.8/image/

strip: i586-pc-linux-gnu-strip --strip-unneeded -R .comment
usr/bin/freepopsd
ecompressdir: bzip2 -9 /usr/share/man
* checking 68 files for package collisions
extensa belcocco #


Ciao
Belcocco

belcocco
Old Dear Hen
Posts: 459
Joined: Sat Nov 29, 2008 18:53
Location: Milan, Italy

Re: aggiornare freepops

Post by belcocco » Tue Dec 09, 2008 17:53

Risolto ........ ho reinstallato da dvd e la prima cosa che ho fatto, dopo emerge --sync && layman -S, è stata, indovinate un po' :D .......
emerge freepops........e voilà, installati senza problemi i due pacchetti lua-5.1.4 e freepops-0.2.8. A questo punto ho scaricato dal sito di freepops il lua di hotmail aggiornato e con claws-mail client ho scaricato la posta. 8)

Lo so che il metodo usato è brutale e da sconsigliare a chiunque, ma nel mio caso era chiaro che avevo fatto dei casini e quindi .... quando ce vò ce vò. :D
Cmq ribadisco che freepops funziona alla grande e se qlc lo vuol provare non ci sono problemi.

Grazie a tutti.
Ciao
Belcocco

Post Reply