aggiornare freepops

Tutto ciò che è pertinente a Sabayon Linux, indipendentemente dall'architettura e dall'ambiente grafico

Moderator: Moderators

belcocco
Old Dear Hen
Posts: 459
Joined: Sat Nov 29, 2008 18:53
Location: Milan, Italy

aggiornare freepops

Post by belcocco » Sat Dec 06, 2008 22:48

Ciao a tutti.
Ho la sabayon 3.5.1 e per scaricare la posta da hotmail ho installato freepops 0.2.7.
Ora però mi sono accorto che il file 'hotmail.lua' aggiornato, preso dal sito http://www.freepops.org/it/viewplugin.p ... in=hotmail e indispensabile per accedere al server di posta, è per la versione 0.2.8 di freepops. Quindi non riesco a scaricare in nessun modo.
E' quindi gioco forza installare la nuova versione.
Vi chiedo: dove la trovo?
Da qui http://www.gentoo-portage.com/net-mail/ ... /Dep#ptabs ho scaricato il file freepops-0.2.8.ebuild, ma cosa ci faccio?
Grazie anticipate per ogni info che mi darete.
Ciao
Belcocco

User avatar
fiorello
Sagely Hen
Posts: 1473
Joined: Mon Aug 13, 2007 14:06
Location: Bourg En Bresse - France

Re: aggiornare freepops

Post by fiorello » Sun Dec 07, 2008 0:45

La versione freepops 0.2.8 si trova in Portage :

Code: Select all

equo remove net-mail/freepops-0.2.7

Code: Select all

emerge net-mail/freepops
Se non è gia fatto , prima di installare con Emerge aggiorna Portage:

http://www.sabayonmania-forum.com/sezio ... e-t238.htm

Ciao :wink:
ASRock Fatal1ty Z68 Professional Gen3 *_* Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz *_* MSI GeForce® GTX 1050 Ti 4GT OC *_* AR5416 Wireless Network Adapter {AR5008802.11(a) bgn} *_* Mémoire totale 8 Gio *_* linux-4.19.0 *_* Sabayon KDE-5 *_*
Image

red.hell
Old Dear Hen
Posts: 862
Joined: Tue Jul 24, 2007 14:38

Re: aggiornare freepops

Post by red.hell » Sun Dec 07, 2008 9:46

che client di posta utilizzi?

se usi thunderbird puoi applicarci l'estensione webmail per il download della posta dai vari hotmail, libero, inwind...

belcocco
Old Dear Hen
Posts: 459
Joined: Sat Nov 29, 2008 18:53
Location: Milan, Italy

Re: aggiornare freepops

Post by belcocco » Sun Dec 07, 2008 12:23

Siete gentilissimi :D

@fiorello
Ti ringrazio per la celere risposta, ma non ho ancora risolto. :cry:
Ho aggiornato con il comando 'emerge portage' ed adesso mi trova la nuova versione di freepops 0.2.8, ma quando lancio 'emerge --ask freepops', trova come dipendenze 'dev-lang/lua-5.1.4' che non riesce a installare e tutto si blocca.
Hai qualche suggerimento da darmi?
Posto il risultato del comando così hai un riferimento oggettivo di quanto mi capita.

extensa belcocco # emerge --ask freepops

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild N ] dev-lang/lua-5.1.4 USE="deprecated readline -static"
[ebuild N ] net-mail/freepops-0.2.8 USE="gnutls"

Would you like to merge these packages? [Yes/No] y

>>> Verifying ebuild manifests

>>> Starting parallel fetch

>>> Emerging (1 of 2) dev-lang/lua-5.1.4
* lua-5.1.4.tar.gz RMD160 SHA1 SHA256 size ;-) ... [ ok ]
* checking ebuild checksums ;-) ... [ ok ]
* checking auxfile checksums ;-) ... [ ok ]
* checking miscfile checksums ;-) ... [ ok ]
>>> Unpacking source...
>>> Unpacking lua-5.1.4.tar.gz to /var/tmp/portage/dev-lang/lua-5.1.4/work
* Applying lua-5.1-make.patch ... [ ok ]
* Applying lua-5.1-module_paths.patch ... [ ok ]
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/dev-lang/lua-5.1.4/work/lua-5.1.4 ...
make -j2 -s CC=i586-pc-linux-gnu-gcc 'CFLAGS= -DLUA_USE_LINUX -Os -march=i686' RPATH=//usr/lib/ LUA_LIBS=-lreadline 'LIB_LIBS=-lm -ldl' V=5.1.4 gentoo_all
Makefile:201: warning: overriding commands for target `liblua.a'
Makefile:51: warning: ignoring old commands for target `liblua.a'
Makefile:204: warning: overriding commands for target `lua'
Makefile:55: warning: ignoring old commands for target `lua'
Makefile:210: warning: overriding commands for target `luac'
Makefile:58: warning: ignoring old commands for target `luac'
>>> Source compiled.
>>> Test phase [not enabled]: dev-lang/lua-5.1.4

>>> Install lua-5.1.4 into /var/tmp/portage/dev-lang/lua-5.1.4/image/ category dev-lang
make -j2 -s INSTALL_TOP=/var/tmp/portage/dev-lang/lua-5.1.4/image//usr/ INSTALL_LIB=/var/tmp/portage/dev-lang/lua-5.1.4/image//usr/lib/ V=5.1.4 gentoo_install
libtool: install: warning: remember to run `libtool --finish //usr/lib/'
>>> Completed installing lua-5.1.4 into /var/tmp/portage/dev-lang/lua-5.1.4/image/

strip: i586-pc-linux-gnu-strip --strip-unneeded -R .comment
usr/lib/liblua.so.5.1.4
usr/bin/lua
usr/bin/luac
usr/lib/liblua.a
ecompressdir: bzip2 -9 /usr/share/man
making executable: usr/lib/liblua.so.5.1.4

>>> Installing dev-lang/lua-5.1.4
* This package will overwrite one or more files that may belong to other
* packages (see list below). You can use a command such as `portageq
* owners / <filename>` to identify the installed package that owns a
* file. If portageq reports that only one package owns a file then do
* NOT file a bug report. A bug report is only useful if it identifies at
* least two or more packages that are known to install the same file(s).
* If a collision occurs and you can not explain where the file came from
* then you should simply ignore the collision since there is not enough
* information to determine if a real problem exists. Please do NOT file
* a bug report at http://bugs.gentoo.org unless you report exactly which
* two packages install the same file(s). Once again, please do NOT file
* a bug report unless you have completely understood the above message.
*
* package dev-lang/lua-5.1.4 NOT merged
*
* Detected file collision(s):
*
* /usr/lib/liblua.a
* /usr/lib/liblua.la
* /usr/lib/pkgconfig/lua.pc
* /usr/include/luaconf.h
* /usr/include/lua.hpp
* /usr/include/lua.h
* /usr/include/lauxlib.h
* /usr/include/lualib.h
* /usr/bin/lua
* /usr/bin/luac
* /usr/share/pixmaps/lua.ico
* /usr/share/man/man1/luac.1.bz2
* /usr/share/man/man1/lua.1.bz2
* /usr/lib/liblua.so.5
* /usr/lib/liblua.so
*
* Searching all installed packages for file collisions...
*
* Press Ctrl-C to Stop
*
* None of the installed packages claim the file(s).
*
* Package 'dev-lang/lua-5.1.4' NOT merged due to file collisions. If
* necessary, refer to your elog messages for the whole content of the
* above message.

>>> Failed to install dev-lang/lua-5.1.4, Log file:

>>> '/var/lib/entropy/logs/dev-lang:lua-5.1.4:20081207-115737.log'


@red.hell
Grazie anche a te per la risposta, non sapevo che con thunderbird c'è la possibilità di scaricare con un semplice plugin.
Uso claws-mail come client di posta e mi sono sempre trovato bene (anche in passato) con 'freepops', quasi quasi provo con thunderbird per vedere come va.

Ciao a tutti e Grazie ancora
Belcocco

crisandbea
Old Dear Hen
Posts: 651
Joined: Tue Feb 12, 2008 11:36
Location: Bosco(SA)

Re: aggiornare freepops

Post by crisandbea » Sun Dec 07, 2008 13:21

postaci il log che hai nel file

Code: Select all

'/var/lib/entropy/logs/dev-lang:lua-5.1.4:20081207-115737.log' 

belcocco
Old Dear Hen
Posts: 459
Joined: Sat Nov 29, 2008 18:53
Location: Milan, Italy

Re: aggiornare freepops

Post by belcocco » Sun Dec 07, 2008 16:07

Eccolo.
[email protected] ~ $ cat /var/lib/entropy/logs/dev-lang:lua-5.1.4:20081207-115737.log
>>> Unpacking source...
>>> Unpacking lua-5.1.4.tar.gz to /var/tmp/portage/dev-lang/lua-5.1.4/work
* Applying lua-5.1-make.patch ... [ ok ]
* Applying lua-5.1-module_paths.patch ... [ ok ]
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/dev-lang/lua-5.1.4/work/lua-5.1.4 ...
make -j2 -s CC=i586-pc-linux-gnu-gcc 'CFLAGS= -DLUA_USE_LINUX -Os -march=i686' RPATH=//usr/lib/ LUA_LIBS=-lreadline 'LIB_LIBS=-lm -ldl' V=5.1.4 gentoo_all
Makefile:201: warning: overriding commands for target `liblua.a'
Makefile:51: warning: ignoring old commands for target `liblua.a'
Makefile:204: warning: overriding commands for target `lua'
Makefile:55: warning: ignoring old commands for target `lua'
Makefile:210: warning: overriding commands for target `luac'
Makefile:58: warning: ignoring old commands for target `luac'
>>> Source compiled.
>>> Test phase [not enabled]: dev-lang/lua-5.1.4

>>> Install lua-5.1.4 into /var/tmp/portage/dev-lang/lua-5.1.4/image/ category dev-lang
make -j2 -s INSTALL_TOP=/var/tmp/portage/dev-lang/lua-5.1.4/image//usr/ INSTALL_LIB=/var/tmp/portage/dev-lang/lua-5.1.4/image//usr/lib/ V=5.1.4 gentoo_install
libtool: install: warning: remember to run `libtool --finish //usr/lib/'
>>> Completed installing lua-5.1.4 into /var/tmp/portage/dev-lang/lua-5.1.4/image/

strip: i586-pc-linux-gnu-strip --strip-unneeded -R .comment
usr/lib/liblua.so.5.1.4
usr/bin/lua
usr/bin/luac
usr/lib/liblua.a
ecompressdir: bzip2 -9 /usr/share/man
making executable: usr/lib/liblua.so.5.1.4
[email protected] ~ $


Grazie
Ciao.
Belcocco

crisandbea
Old Dear Hen
Posts: 651
Joined: Tue Feb 12, 2008 11:36
Location: Bosco(SA)

Re: aggiornare freepops

Post by crisandbea » Sun Dec 07, 2008 17:13

prova a dare emerge in questo modo:

Code: Select all

USE="-deprecated" emerge -av  freepops  
verifica che viene reinstallato anche dev-lang/lua-5.1.4.

ciauz

belcocco
Old Dear Hen
Posts: 459
Joined: Sat Nov 29, 2008 18:53
Location: Milan, Italy

Re: aggiornare freepops

Post by belcocco » Sun Dec 07, 2008 17:40

Dando il comando suggerito ecco cosa ottengo:

extensa belcocco # USE="-deprecated" emerge -av freepops

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=dev-lang/lua-5.1.3[deprecated]".
!!! One of the following packages is required to complete your request:
- dev-lang/lua-5.1.4 (Change USE: +deprecated)
(dependency required by "net-mail/freepops-0.2.8" [ebuild])
(dependency required by "freepops" [argument])

extensa belcocco #


Grazie
Ciao
Belcocco

crisandbea
Old Dear Hen
Posts: 651
Joined: Tue Feb 12, 2008 11:36
Location: Bosco(SA)

Re: aggiornare freepops

Post by crisandbea » Sun Dec 07, 2008 18:17

belcocco wrote:Dando il comando suggerito ecco cosa ottengo:

extensa belcocco # USE="-deprecated" emerge -av freepops

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=dev-lang/lua-5.1.3[deprecated]".
!!! One of the following packages is required to complete your request:
- dev-lang/lua-5.1.4 (Change USE: +deprecated)
(dependency required by "net-mail/freepops-0.2.8" [ebuild])
(dependency required by "freepops" [argument])

extensa belcocco #


Grazie
Ciao
Belcocco
e si quella flag ci vuole , infatti nell'ebuild c'è. però nel log non vedo errori l'unico warning è questo

Code: Select all

libtool --finish /usr/lib/
dove ti chiede
di eseguire tale comando. prova a darlo.

belcocco
Old Dear Hen
Posts: 459
Joined: Sat Nov 29, 2008 18:53
Location: Milan, Italy

Re: aggiornare freepops

Post by belcocco » Sun Dec 07, 2008 19:09

Fatto, ma il risultato è negativo. Tutto come prima.
Ecco i comandi.

extensa belcocco # libtool --finish //usr/lib/
PATH="$PATH:/sbin" ldconfig -n //usr/lib/
----------------------------------------------------------------------
Libraries have been installed in:
//usr/lib/

If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
- add LIBDIR to the `LD_LIBRARY_PATH' environment variable
during execution
- add LIBDIR to the `LD_RUN_PATH' environment variable
during linking
- use the `-Wl,--rpath -Wl,LIBDIR' linker flag
- have your system administrator add LIBDIR to `/etc/ld.so.conf'

See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so(8) manual pages.
----------------------------------------------------------------------
extensa belcocco # USE="-deprecated" emerge -av freepops

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=dev-lang/lua-5.1.3[deprecated]".
!!! One of the following packages is required to complete your request:
- dev-lang/lua-5.1.4 (Change USE: +deprecated)
(dependency required by "net-mail/freepops-0.2.8" [ebuild])
(dependency required by "freepops" [argument])

extensa belcocco #


Se ci fossero altre dritte.........???? :)
Io non so proprio cosa fare/pensare (purtroppo). :cry:
Grazie comunque a tutti. :D
Ciao
Belcocco

Post Reply