opengl, XGL, ati e 3.0b vs RC2

Tutto ciò che è pertinente a Sabayon Linux, indipendentemente dall'architettura e dall'ambiente grafico

Moderator: Moderators

lxnay
Land Owner
Posts: 3596
Joined: Thu Oct 13, 2005 23:16
Location: Italy
Contact:

Post by lxnay » Thu Oct 05, 2006 13:59

seth,
per risolvere questo problema, avrei bisogno che tu provassi, dalla RC2, ad usare i driver open, fai il boot (sulla RC2), con:

Code: Select all

gentoo xgl opengl=xorg-x11 xdriver=radeon
Ad ogni modo, hai provato XGL sulla 3.0? Perché il problema potrebbe essere semplicemente in AIGLX (infatti qui con XGL non freeza nulla).

Inoltre, mi potresti dire se, senza AIGLX, con i driver open sulla 3.0, il direct rendering è attivato? Da utente normale (NON ROOT):

Code: Select all

glxinfo | grep direct
grazie :)

P.S.: povera 9600...
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+

seth
Young Hen
Posts: 31
Joined: Fri Aug 18, 2006 15:58
Location: Italy

Post by seth » Thu Oct 05, 2006 15:49

Innanzitutto grazie a te che hai fatto sabayon e che mi aiuti.

sono in attesa di farmi restituire il dvd della rc2 che ho prestato a degli amici.

Ad ogni modo, xgl non va (decentemente) nè con la 3.0 dvd nè con la miniedition se non con xorg-x11

Code: Select all

 sabayon xdriver=radeon opengl=xorg-x11 
è l'unica cosa che entra. Mi da' con il comando che mi hai gentilmente suggerito:

Code: Select all

direct rendering: No
OpenGL renderer string: Mesa GLX indirect
le altre si ferma in terminale loggato root e mi dice ovviamente no display

Nano Malefico
Baby Hen
Posts: 3
Joined: Wed Oct 04, 2006 23:01

Post by Nano Malefico » Thu Oct 05, 2006 19:07

Io ho una ati radeon 9600 pro, ho fatto diversi tentativi con esiti differenti ma comunque INSUFFICIENTI! In boot con LiveCd...

1) sabayon xgl --> si blocca durante il caricamento

2) sabayon opengl=xorg-x11 xgl --> durante il caricamento da un FATAL :ERROR INSERTING i8xx_tco ---> riesce cmq a caricare il o.s. --> xgl va tremendamente a scatti!

3) sabayon opengl=xorg-x11 xdriver=fgrlx xgl --> idem problemi citati al punto 2)

4) sabayon opengl=xorg-x11 xdriver=fgrlx aiglx --> si blocca durante caricamento!

Ringrazio seth per aver cercato di aiutarmi ma siamo sempre Punto & A Capo!

NOTA BENE: Ricordo che ieri sera avevo provato Kororaa LiveCD 0.2 XGL: Xgl girava fluidissimo anke con un filmato in riproduzione ect..

Quindi che devo fare???????

seth
Young Hen
Posts: 31
Joined: Fri Aug 18, 2006 15:58
Location: Italy

Post by seth » Fri Oct 06, 2006 15:27

sto facendo qualche prova ma non riesco a ottenere alcun risultato. Se la cosa è risolvibile bene altrimenti pazienza.
Continuerò comunque a promuovere sabayon tra chi ha nvidia, mi dispiace sinceramente che ci siano proiblemi. Tieni duro e confidiamo nel buon LxNay e vediamo che succede

seth
Young Hen
Posts: 31
Joined: Fri Aug 18, 2006 15:58
Location: Italy

Post by seth » Fri Oct 06, 2006 16:57

postati nel thread in inglese i risultati ai comandi che hai indicato... spero diano indicazioni perchè con xorg-x11 siamo a livelli da buon vecchio 386... anche internet va lento, oltre un minuto per un post, le finestre da gnome sono posizionate sbagliate, la tastiera ora la prende ita ma con tinua a dare l'errore fatidico all'avvio. Ma basterebbe risolvere il problema ati... che ho visto qua e là che hanno in molti. incrocio le dita perchè questa distro merita successo

Cloud 68
Baby Hen
Posts: 4
Joined: Mon Oct 23, 2006 10:24
Location: palermo

ati 9550 ok

Post by Cloud 68 » Mon Oct 23, 2006 11:02

:D Ragazzi ciao a tutti. E' la prima volta che mi registro a un forum e mando un post, ma lo dovevo
fare in quanto devo ringraziare colui o coloro che hanno creato questa distro. E' fantastica !!!.
Inoltre volevo dire a seth e a chi puo' servire che a modo mio ho risolto il problema con queste
MALEDETTE ATI :evil: :evil: . Innanzitutto ho scaricato Sabayon 3.1 dopo essere uscito pazzo con la distro presente in Linuxpro di novembre, e inizialmente avevo problemi anche peggiori in quanto con le
varie combinazioni di comandi al boot del live/dvd lo schermo si impallava. Tengo premesso che io
ho un Pentium 4 a 2,4 ghz e una ati radeon 9550. Alla fine mi sono deciso ad implementare nella
configurazione di boot anche la risoluzione e cioè :

"sabayon xgl opengl=ati res=<1024*768>"

e magia delle magie funziona tutto alla perfezione anche beryl .Troppo forti gli effetti di scomparsa delle finestre e la ruotazione 3d dei desktop. Mi auguro di essere stato utile a qualcuno.
CIAOO!

seth
Young Hen
Posts: 31
Joined: Fri Aug 18, 2006 15:58
Location: Italy

Post by seth » Mon Oct 23, 2006 11:21

grazie 1000 per l'aiuto Cloud, proverò quanto prima ;)

Post Reply