Chiarimenti per emerge

Tutto ciò che è pertinente a Sabayon Linux, indipendentemente dall'architettura e dall'ambiente grafico

Moderator: Moderators

Chiarimenti per emerge

Postby py67 » Thu Sep 28, 2006 13:14

Intanto un !!! FANTASTICO !!! :cheers: per la versione mini ( CD )di Sabayon Linux 3.0, ora tentando di fare emerge pacchetto, ricevo il seguente errore.

!!! Invalid PORTDIR_OVERLAY (not a dir): '/usr/portage/local/layman/sabayon'
!!! Invalid PORTDIR_OVERLAY (not a dir): '/usr/portage/local/layman/gentopia'
!!! Invalid PORTDIR_OVERLAY (not a dir): '/usr/portage/local/layman/portage-xgl'
!!! Invalid PORTDIR_OVERLAY (not a dir): '/usr/portage/local/layman/sabayon'
!!! Invalid PORTDIR_OVERLAY (not a dir): '/usr/portage/local/layman/gentopia'
!!! Invalid PORTDIR_OVERLAY (not a dir): '/usr/portage/local/layman/portage-xgl'

Cosa dovrei impostare?

Ciao e grazie
py67
Simple Hen
 
Posts: 57
Joined: Wed Dec 28, 2005 15:01

Postby lxnay » Thu Sep 28, 2006 14:27

Che strano, questa cosa non sarebbe dovuta accadere...
ad ogni modo:
Code: Select all
layman -f -a sabayon
layman -f -a portage-xgl
layman -f -a gentopia
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3596
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Postby py67 » Thu Sep 28, 2006 19:30

lxnay wrote:Che strano, questa cosa non sarebbe dovuta accadere...
ad ogni modo:
Code: Select all
layman -f -a sabayon
layman -f -a portage-xgl
layman -f -a gentopia


Facendo come hai detto sopre ricevo i seguenti errori:

sabayonx86
este37 # layman -f -a sabayon
* Failed to add overlay "sabayon".
* Error was: Binary /usr/bin/svn seems to be missing! Overlay type "svn" not sup ported. Did you emerge dev-util/subversion?
sabayonx86 este37 # layman -f -a portage-xgl
* Failed to add overlay "portage-xgl".
* Error was: Binary /usr/bin/svn seems to be missing! Overlay type "svn" not sup ported. Did you emerge dev-util/subversion?
sabayonx86
este37 # layman -f -a gentopia
* Failed to add overlay "gentopia".
* Error was: Binary /usr/bin/svn seems to be missing! Overlay type "svn" not sup ported. Did you emerge dev-util/subversion?
sabayonx86 este37 #
py67
Simple Hen
 
Posts: 57
Joined: Wed Dec 28, 2005 15:01

Postby retomi » Thu Sep 28, 2006 19:50

py67 wrote:
lxnay wrote:Che strano, questa cosa non sarebbe dovuta accadere...
ad ogni modo:
Code: Select all
layman -f -a sabayon
layman -f -a portage-xgl
layman -f -a gentopia


Facendo come hai detto sopre ricevo i seguenti errori:

sabayonx86
este37 # layman -f -a sabayon
* Failed to add overlay "sabayon".
* Error was: Binary /usr/bin/svn seems to be missing! Overlay type "svn" not sup ported. Did you emerge dev-util/subversion?
sabayonx86 este37 # layman -f -a portage-xgl
* Failed to add overlay "portage-xgl".
* Error was: Binary /usr/bin/svn seems to be missing! Overlay type "svn" not sup ported. Did you emerge dev-util/subversion?
sabayonx86
este37 # layman -f -a gentopia
* Failed to add overlay "gentopia".
* Error was: Binary /usr/bin/svn seems to be missing! Overlay type "svn" not sup ported. Did you emerge dev-util/subversion?
sabayonx86 este37 #

quoto in toto. accade anche a me. Ho già fatto emerge --sync e emerge potage ma gli errori persistono
adesso ho lanciato emerge sabayon ma credo di aver fatto la cosa meno giusta :(
retomi
Baby Hen
 
Posts: 5
Joined: Thu Sep 28, 2006 8:22
Location: Verona

Postby py67 » Thu Sep 28, 2006 20:06

...comunque i programmi si installano lo stesso. Ho lanciato aMule, mi ha dato i soliti errori come sopra ma poi la compilazione ha continuato fino alla fine.
py67
Simple Hen
 
Posts: 57
Joined: Wed Dec 28, 2005 15:01

Postby lxnay » Thu Sep 28, 2006 20:51

Mi piacerebbe che voi leggeste gli errori che vi da prima di tornare qui come dei ciuchini copia-incollosi :D Il programma dice chiaramente che dovete installare prima di tutto subversion, quindi:

Code: Select all
emerge dev-util/subversion
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3596
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Postby py67 » Thu Sep 28, 2006 21:08

lxnay wrote:Mi piacerebbe che voi leggeste gli errori che vi da prima di tornare qui come dei ciuchini copia-incollosi :D Il programma dice chiaramente che dovete installare prima di tutto subversion, quindi:

Code: Select all
emerge dev-util/subversion


Hai raggione a dire che non leggiamo mai, soprattutto per la foga di usare una distro cosi esaltante, ma aime, quell'errore l'avevo notato e avevo fatto come suggerito, ora dopo che me lo hai fatto notare l'ho rifatto, pensando di aver sbagliato qualcosa ma ricevo i seguenti messaggi, riassunti.

!!! ERROR: The active vm could not be found
!!! ERROR: The active vm could not be found
!!! ERROR: The active vm could not be found
!!! ERROR: The active vm could not be found
!!! ERROR: The active vm could not be found
!!! ERROR: The active vm could not be found
!!! ERROR: The active vm could not be found
...

!!! ERROR: The active vm could not be found
!!! ERROR: The active vm could not be found
!!! ERROR: The active vm could not be found
!!! ERROR: The active vm could not be found
!!! ERROR: The active vm could not be found
!!! ERROR: The active vm could not be found
!!! ERROR: The active vm could not be found
...

!!! Please attach the following file when filing a report to bugs.gentoo.org:
!!! /var/tmp/portage/subversion-1.4.0/work/subversion-1.4.0/config.log

!!! ERROR: dev-util/subversion-1.4.0 failed.
Call stack:
ebuild.sh, line 1546: Called dyn_compile
ebuild.sh, line 937: Called src_compile
subversion-1.4.0.ebuild, line 101: Called econf '--with-apr=/usr' '--with-ap r-util=/usr' '--with-apxs=/usr/sbin/apxs2' '--enable-javahl' '--without-jikes' ' --with-jdk=' '--with-swig' '--with-neon=/usr' '--with-berkeley-db' '--with-pytho n' '--enable-nls' '--with-apr=/usr' '--with-apr-util=/usr' '--disable-experiment al-libtool' '--disable-mod-activation'
ebuild.sh, line 540: Called die

!!! econf failed
!!! If you need support, post the topmost build error, and the call stack if rel evant.

!!! When you file a bug report, please include the following information:
GENTOO_VM= CLASSPATH="" JAVA_HOME=""
JAVACFLAGS="-target 1.4" COMPILER=""
and of course, the output of emerge --info


E questo è emerge --info:

sabayonx86 este37 # emerge --info
!!! Invalid PORTDIR_OVERLAY (not a dir): '/usr/portage/local/layman/sabayon'
!!! Invalid PORTDIR_OVERLAY (not a dir): '/usr/portage/local/layman/gentopia'
!!! Invalid PORTDIR_OVERLAY (not a dir): '/usr/portage/local/layman/portage-xgl'
!!! Invalid PORTDIR_OVERLAY (not a dir): '/usr/portage/local/layman/sabayon'
!!! Invalid PORTDIR_OVERLAY (not a dir): '/usr/portage/local/layman/gentopia'
!!! Invalid PORTDIR_OVERLAY (not a dir): '/usr/portage/local/layman/portage-xgl'
Portage 2.1.2_pre1-r4 (default-linux/x86/2006.0, gcc-4.1.1, glibc-2.4-r3, 2.6.18-gentoo i686)
=================================================================
System uname: 2.6.18-gentoo i686 AMD Athlon(tm) 64 Processor 3200+
Gentoo Base System version 1.12.4
Last Sync: Thu, 28 Sep 2006 11:30:01 +0000
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.3.3, 2.0.27-r1
dev-lang/python: 2.4.3-r3
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache: [Not Present]
dev-util/confcache: [Not Present]
sys-apps/sandbox: 1.2.18.1
sys-devel/autoconf: 2.13, 2.60
sys-devel/automake: 1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils: 2.17
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool: 1.5.22
virtual/os-headers: 2.6.17
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i586-pc-linux-gnu"
CFLAGS="-Os -march=i586 -mno-tls-direct-seg-refs -mmmx -m32"
CHOST="i586-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/NX/etc /usr/NX/home /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/share/config/kdm/ /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/splash /etc/terminfo"
CXXFLAGS="-Os -march=i586 -mno-tls-direct-seg-refs -mmmx -m32"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/dis ... ons/gentoo "
LANG="it_IT.UTF-8"
LC_ALL="it_IT.UTF-8"
LINGUAS="en it es de gr fr jp ga hu lt nb fi el pt ro ru sk sl sr sv zh_CN da ja en_GB nl pl zh_TW"
MAKEOPTS="-j2 -s "
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 7Zip X a52 aac accessibility acpi ada aim alsa amarok apache2 arts artswrappersuid asf audiofile avahi berkdb bidi bitmap-fonts bluetooth cairo cdda chm cjk clearcase cli commercial config_wizard cpudetection crypt css cups dbus dga dlloader dri dts dv dvb dvd dvdr dvdread dxr3 eds effects elibc_glibc emboss encode esd evo exscalibar ext-man ext-rtf ext-tex extraicons extramodules fame fat ffmpeg fftw firefox flac flash foomatic-db foomaticdb fortran freetype gcj gdbm gif gimpprint glitz gnokii gnome gnutls gphoto2 gpm gs gstreamer gtk gtk2 hal hfs icq ieee1394 imap imlib inkjar input_devices_acecad input_devices_aiptek input_devices_calcomp input_devices_citron input_devices_digitaledge input_devices_dmc input_devices_dynapro input_devices_elo2300 input_devices_elographics input_devices_evdev input_devices_fpit input_devices_hyperpen input_devices_jamstudio input_devices_joystick input_devices_keyboard input_devices_magellan input_devices_microtouch input_devices_mouse input_devices_mutouch input_devices_palmax input_devices_penmount input_devices_spaceorb input_devices_summa input_devices_synaptics input_devices_tek4957 input_devices_ur98 input_devices_vmmouse input_devices_void ipod ipv6 irc irda isdnlog jabber jack java jfs joystick jpeg kde kdeenablefinal kdehiddenvisibility kerberos kernel_linux kqemu krb4 lcd libao libcaca libclamav libg++ libwww linguas_da linguas_de linguas_el linguas_en linguas_en_GB linguas_es linguas_fi linguas_fr linguas_ga linguas_gr linguas_hu linguas_it linguas_ja linguas_jp linguas_lt linguas_nb linguas_nl linguas_pl linguas_pt linguas_ro linguas_ru linguas_sk linguas_sl linguas_sr linguas_sv linguas_zh_CN linguas_zh_TW live livecd lj lm_sensors logitech-mouse lzo mad mail matroska mikmod mjpeg mmx mono motif moznocompose moznoirc moznomail mp3 mpeg msn musepack musicbrainz mysql mythtv ncurses network new-login nls nptl nptlonly nsplugin ntfs nvidia ogg ole openexr opengl pam pam_console pascal pcmcia pcre pda pdf perl php plugin png postgres povray ppds pppd pwdb python qt qt3 qt4 quicktime quotas rar rdesktop readline real reflection reiser4 reiserfs rss ruby samba scanner sdl session skins slp sms sndfile speech speex spell spl spreadsheet sql ssl stream streams subversion svg switch_all_desktops sysfs tcpd theora tiff truetype truetype-fonts type1-fonts udev unicode userland_GNU v4l v4l2 vcd video_cards_apm video_cards_ark video_cards_chips video_cards_cirrus video_cards_cyrix video_cards_dummy video_cards_fbdev video_cards_fglrx video_cards_glint video_cards_i128 video_cards_i740 video_cards_i810 video_cards_imstt video_cards_mach64 video_cards_mga video_cards_neomagic video_cards_nsc video_cards_nv video_cards_nvidia video_cards_r128 video_cards_radeon video_cards_rendition video_cards_s3 video_cards_s3virge video_cards_savage video_cards_siliconmotion video_cards_sis video_cards_sisusb video_cards_tdfx video_cards_tga video_cards_trident video_cards_tseng video_cards_v4l video_cards_vesa video_cards_vga video_cards_via video_cards_vmware video_cards_voodoo visualization voice vorbis weather webservices wifi win32codecs winbind wmf wxwindows xfs xine xinerama xml xmms xorg xosd xpm xprint xscreensaver xsl xv xvid xvmc yahoo zeroconf zlib"
Unset: CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Scusami per il post gigantesco
py67
Simple Hen
 
Posts: 57
Joined: Wed Dec 28, 2005 15:01

Postby lxnay » Thu Sep 28, 2006 22:22

La miniEdition, per sua natura e definizione, è una distro abbastanza minimale: non contiene Java.
Per installare rapidamente subversion senza installare anche Java:

Code: Select all
USE="-java" emerge subversion


Per non installare pure apache:
Code: Select all
USE="-java -apache2" emerge subversion
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3596
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Postby lxnay » Thu Sep 28, 2006 22:23

Per installare Java SDK 1.5.0 (NB: ieri avevo dei problemi a scaricare il pacchetto):
Code: Select all
emerge sun-jdk


Nel caso, puoi cercare tutti i JDK disponibili con:
Code: Select all
emerge -s jdk


Sicuramente blackdown-jdk funziona:
Code: Select all
emerge blackdown-jdk
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3596
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Postby py67 » Thu Sep 28, 2006 23:01

Grande Lxnay :D :D , risolto il problema, dopo il tuo ultimo consiglio ho ridato i comandi:

layman -f -a sabayon
layman -f -a portage-xgl
layman -f -a gentopia

Ora tutto ok, ti prego un ultimo consiglio poi andro' di man
la rete funziona tutto Ok ma ad ogni riavvio /etc/resolv.conf mi si azzera.
py67
Simple Hen
 
Posts: 57
Joined: Wed Dec 28, 2005 15:01

Next

Return to Sabayon Linux Discussioni Generali

Who is online

Users browsing this forum: No registered users and 1 guest

cron