SL3.4 (rt73 wireless) iwpriv command still not working

Discuss all artwork and development - Suggestions needed

Moderator: Moderators

SL3.4 (rt73 wireless) iwpriv command still not working

Postby dave_p_b » Wed Apr 18, 2007 22:06

Hi

I'm using an belkin (rt73) wireless card and my router has WPA2PSK encryption on it. I use the iwpriv command to connect to my router seen below:
ifconfig rausb0 up
sleep 1
iwpriv rausb0 set AuthMode=WPA2PSK
sleep 0.2
iwpriv rausb0 set EncrypType=AES
sleep 0.2
iwpriv rausb0 set SSID="BTHomeHub-B061"
sleep 0.2
iwpriv rausb0 set WPAPSK="**********"
sleep 0.5
iwpriv rausb0 set SSID="BTHomeHub-B061"
sleep 0.5
dhclient rausb0
echo 'nameserver 192.168.1.254' > /etc/resolv.conf

I only managed to get this to work with SL 3.3 by recompiling the Sabayon kernel removing lots of stuff from the kernel config file. Before I done this, the command iwpriv would only return what's shown below:
rausb0 no private ioctls
Now, after recompiling the kernel, the command iwpriv returns what's shown below when I run it:
rausb0 Available private ioctls :
set (8BE2) : set 1024 char & get 0
adhocOfdm (8BE6) : set 1 int & get 0
stat (8BE9) : set 1024 char & get 1024 char
get_site_survey (8BEF) : set 1024 char & get 1024 char
get_RaAP_Cfg (8BF1) : set 1024 char & get 0
forceprism (8BF2) : set 1024 char & get 0
rfmontx (8BEC) : set 1024 char & get 0
get_rfmontx (8BED) : set 0 & get 1 int
auth (8BE7) : set 1 int & get 0
enc (8BE8) : set 1 int & get 0
wpapsk (8BEA) : set 64 char & get 0
psm (8BEB) : set 1 int & get 0

I was hoping the SabayonLinux 3.4 Loop 1 would have fixed the issue with iwpriv but it looks like it hasn't. It's better than the original SL 3.3 but the iwpriv command only returns what's shown below:
wmaster0 no private ioctls.

wlan0 Available private ioctls :
param (8BE0) : set 2 int & get 0
get_param (8BE1) : set 1 int & get 1 int
test_param (8BE4) : set 2 int & get 0

The iwpriv command will not let me set any of the settings (listed at the top of the page) in order to connect to my router.
Looks like I'll have to recompile the SL3.4 kernel taking all of the stuff out of it like I had to before.

Any help would be most appreciated.

Thanks

Dave
dave_p_b
Old Dear Hen
 
Posts: 607
Joined: Fri Dec 15, 2006 1:39
Location: Exeter, UK

Postby dave_p_b » Sun Apr 22, 2007 18:19

Hi

Could any of the developers shed any light on this issue. I think it's going a bit too far when I have to recompile the kernel just to get Internet access. Before the inclusion of all the RaLink stuff into the kernel everything worked fine. (version 3.2*)
The iwpriv command is very important to the RaLink opensource drivers as it is the only way to connect to WPA(2) networks. Whatever is put into the kernel stops this command working properly.

I hope this can be resolved in version 3.4.

Any help would be most appreciated. SabayonLinux's great :)

Dave
dave_p_b
Old Dear Hen
 
Posts: 607
Joined: Fri Dec 15, 2006 1:39
Location: Exeter, UK

Postby Dark_MaGe » Thu May 03, 2007 12:24

it has been fixed on the new kernel 2.6.21 sabayon-sources... just use the inkernel module and networkmanager it works without any issues here
Image
Dark_MaGe
Your Farmer
 
Posts: 1699
Joined: Thu Jun 29, 2006 8:19
Location: Catania Italy

Postby dave_p_b » Thu May 03, 2007 21:17

Thanks

I'll try that. I upgraded to the new kernel a few days ago. I guess it wasn't fixed then. I'll give it another go and recompile the kernel.

Cheers

Dave
dave_p_b
Old Dear Hen
 
Posts: 607
Joined: Fri Dec 15, 2006 1:39
Location: Exeter, UK

Postby dave_p_b » Sat May 05, 2007 5:39

Hi Dark_MaGe

Tried the latest Sabayon kernel and the inbuild modules for rt73 driver. I tried using knetworkmanager along with NetworkManager-0.6.5 to connect to WPA2PSK network. KNetworkManager didn't get passed 28%. The output from dmesg was as follows:
[ 363.212166] wlan0: Initial auth_alg=0
[ 363.212175] wlan0: authenticate with AP 00:14:7f:94:4e:90
[ 363.221488] wlan0: RX authentication from 00:14:7f:94:4e:90 (alg=0 transaction=2 status=0)
[ 363.221493] wlan0: authenticated
[ 363.221496] wlan0: associate with AP 00:14:7f:94:4e:90
[ 363.224650] wlan0: RX AssocResp from 00:14:7f:94:4e:90 (capab=0x411 status=0 aid=1)
[ 363.224654] wlan0: associated
[ 363.224687] wlan0: WMM queue=2 aci=0 acm=0 aifs=3 cWmin=15 cWmax=1023 burst=0
[ 363.224691] wlan0: WMM queue=3 aci=1 acm=0 aifs=7 cWmin=15 cWmax=1023 burst=0
[ 363.224694] wlan0: WMM queue=1 aci=2 acm=0 aifs=2 cWmin=7 cWmax=15 burst=30
[ 363.224697] wlan0: WMM queue=0 aci=3 acm=0 aifs=2 cWmin=3 cWmax=7 burst=15
[ 363.283814] wlan0: CTS protection enabled (BSSID=00:14:7f:94:4e:90)
[ 366.220381] wlan0: RX WEP frame with unknown keyidx 1 (A1=ff:ff:ff:ff:ff:ff A2=00:14:7f:94:4e:90 A3=00:14:7f:94:4e:8e)
[ 366.221254] wlan0: RX WEP frame with unknown keyidx 1 (A1=ff:ff:ff:ff:ff:ff A2=00:14:7f:94:4e:90 A3=00:14:7f:94:4e:8e)
[ 372.185090] wlan0: disassociate(reason=3)

Didn't try with WEP network.

Any Ideas?

Thanks

Dave
dave_p_b
Old Dear Hen
 
Posts: 607
Joined: Fri Dec 15, 2006 1:39
Location: Exeter, UK

Postby RedFoxxy66 » Sat Jun 09, 2007 21:40

---
RedFoxxy66
Baby Hen
 
Posts: 5
Joined: Thu Jun 07, 2007 19:16


Return to Artwork and Development Suggestions

Who is online

Users browsing this forum: No registered users and 3 guests