Search found 12 matches

by welele
Tue Mar 31, 2020 15:45
Forum: Software in General
Topic: python / tkinter
Replies: 1
Views: 1193

Re: python / tkinter

Hi, tkinter is not present by default in python package. It is pulled by [tk] useflag, which is not present in sabayon package. You need to emerge dev-lang/python with tk use flag enable : USE="tk" emerge dev-lang/python or add "dev-lang/python tk" to a file /etc/portage/package.use/02-python.use an...
by welele
Thu Mar 26, 2020 16:46
Forum: Entropy|Equo|Rigo Package Managers
Topic: qt-5.14.1-r1 and dev-qt/qtwebkit-5.212.0_pre20190629 issue
Replies: 3
Views: 1887

Re: qt-5.14.1-r1 and dev-qt/qtwebkit-5.212.0_pre20190629 issue

dev-qt/qtwebkit-5.212.0_pre20190629 in repo still bogus (linked with old qt).
A "emerge dev-qt/qtwebkit-5.212.0_pre20190629" solve my previous issue (emerging zeal). But the package in repo still bogus and need to be recompiled over new version of qt.
by welele
Wed Mar 04, 2020 10:59
Forum: Entropy|Equo|Rigo Package Managers
Topic: qt-5.14.1-r1 and dev-qt/qtwebkit-5.212.0_pre20190629 issue
Replies: 3
Views: 1887

qt-5.14.1-r1 and dev-qt/qtwebkit-5.212.0_pre20190629 issue

Since the upgrade to qt-5.14.1 familly, I have issue with compilation over qtwebkit. I have qt-5.14.1-r1 and dev-qt/qtwebkit-5.212.0_pre20190629 installed with equo, from sabayonlinux.org. A "emerge zeal" (which depend on qtwebit) fail with : -- Installing in the same prefix as Qt, adopting their pa...
by welele
Sat Feb 01, 2020 15:30
Forum: Software in General
Topic: dev-python/notebook-5.2.1 incompatible with www-servers/tornado-5.1
Replies: 1
Views: 334

dev-python/notebook-5.2.1 incompatible with www-servers/tornado-5.1

notebook-5.2.1 is broken since 2019-12-31 and update of www-servers/tornado-5.1 jupyter-notebook fail with : TypeError: __init__() got an unexpected keyword argument 'io_loop' This is a incompatibility between version, as stated in : https://github.com/jupyter/help/issues/324 Notebook is compatible ...
by welele
Sat Oct 05, 2019 22:26
Forum: Entropy|Equo|Rigo Package Managers
Topic: app-text/docbook-sgml-utils dependance conflict on docbook-xml-smple-dtd
Replies: 1
Views: 3847

app-text/docbook-sgml-utils dependance conflict on docbook-xml-smple-dtd

Installing docbook-sgml-utils result in a dependancy conflict : equo i -p docbook-sgml-utils ☢ @@ Conflicting packages were pulled in: ☛ ☛ # app-text/docbook-xml-simple-dtd-1.[email protected].org ╠ (required by: app-text/docbook-sgml-utils-0.6.[email protected].org) ☛ # app-text/docbook-xml-simple...
by welele
Wed Aug 21, 2019 14:35
Forum: ISO Testing & Molecule
Topic: Remastering Sabayon_Linux_DAILY_amd64_Xfce.is
Replies: 2
Views: 3715

Re: Remastering Sabayon_Linux_DAILY_amd64_Xfce.is

The spc file : https://pastebin.com/TT4QtLsC The spec is a copy of sabayon-amd64-xfce.spec of the sabayon molecule github repository, with some additionnal package in "package_to_add:" . When i change "%env source_iso: ${SABAYON_MOLECULE_HOME:-/sabayon}/iso/Sabayon_Linux_${ISO_TAG:-LATEST}_amd64_Spi...
by welele
Sat Aug 17, 2019 8:51
Forum: ISO Testing & Molecule
Topic: Remastering Sabayon_Linux_DAILY_amd64_Xfce.is
Replies: 2
Views: 3715

Remastering Sabayon_Linux_DAILY_amd64_Xfce.is

Hi, At the moment, i build a custom iso form spinbase image using molecule and a custom .spec file. But is there a way to start from the Xfce image instead. I try changing the source iso in .spec file, but molecule can't handle the squash file of the Xfce image (in fact, molecule try to mount livecd...
by welele
Sun Jul 08, 2018 12:33
Forum: Entropy|Equo|Rigo Package Managers
Topic: Setting up a custom repo
Replies: 0
Views: 3412

Setting up a custom repo

Hi, I want to manage a custom repository. I want to automate the building process of package with community-buildspec, following this wiki : https://wiki.sabayon.org/index.php?title=HOWTO:_Contributing_to_SCR Provisionning and running the machine via vagrant is ok (i had to customise a bit the image...
by welele
Wed May 02, 2018 16:30
Forum: Software in General
Topic: Trouble with ncurses-6.1-r2
Replies: 4
Views: 1002

Trouble with ncurses-6.1-r2

Hi my system is bogus since updating ncurses to 6.1-r2. Launching cfdisk, testdisk and several program result in a seg fault. In both case, gdb indicate a segfault in termattrs_sp() in /lib/libncusesw.so.6. According to gentoo bugzilla, it seems to be linked to tinfo use flag. I build a custom versi...