Search found 13 matches

by twhite
Fri Jan 25, 2019 2:39
Forum: Sabayon Linux General Discussion
Topic: KDE fails at xinit after recent update [Solved]
Replies: 10
Views: 423

Re: KDE fails at xinit after recent update [Solved]

I just finish a new large update of Sabayon and KDE is now working. Other than the update any changes I made were put back like the original. I can only guess as to the cause, perhaps a kernel that was installed in the update just before it broke, maybe it didn't work with the graphics driver.
by twhite
Thu Jan 17, 2019 4:27
Forum: Sabayon Linux General Discussion
Topic: KDE fails at xinit after recent update [Solved]
Replies: 10
Views: 423

Re: KDE fails at xinit after recent update

I read at https://wiki.ubuntu.com/X/Troubleshooting/Freeze that most of the GPU freezes tend to be bugs in the kernel. I was at 4.4 so I changed to 4.9. That didn't work. I'll try some different versions and see what happens. They also suggested that when the freeze happens after an update try to ba...
by twhite
Wed Jan 16, 2019 19:26
Forum: Sabayon Linux General Discussion
Topic: KDE fails at xinit after recent update [Solved]
Replies: 10
Views: 423

Re: KDE fails at xinit after recent update

I don't know much about this but it looks like it is locking up within Xorg. Notice the "running task" below. Xorg itself wasn't updated but maybe a configuration or permission was changed. journalctl --since "2019-1-9 09:18:00" Jan 09 09:20:00 sabayonx86-64 kernel: INFO: rcu_sched self-detected sta...
by twhite
Wed Jan 16, 2019 18:54
Forum: Sabayon Linux General Discussion
Topic: KDE fails at xinit after recent update [Solved]
Replies: 10
Views: 423

Re: KDE fails at xinit after recent update

From lspci VGA compatible controller: Intel corporation Haswell-ULT Intregrated Graphics Controller (rev09) From Xorg.1.log [174116.261] (II) LoadModule: "intel" [174116.262] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so [174116.262] (II) Module intel: vendor="X.Org Foundation" [174116.2...
by twhite
Tue Jan 15, 2019 0:16
Forum: Sabayon Linux General Discussion
Topic: KDE fails at xinit after recent update [Solved]
Replies: 10
Views: 423

Re: KDE fails at xinit after recent update

Thanks for responding... I was using sddm and the file /etc/systemd/system/display-manager.service looked the same as yours. I disabled sddm, installed lightdm and enabled it then tried it again with the same result of freezing with trying to load the GUI. For now I have disabled the GUI from bootin...
by twhite
Thu Jan 10, 2019 23:17
Forum: Sabayon Linux General Discussion
Topic: KDE fails at xinit after recent update [Solved]
Replies: 10
Views: 423

KDE fails at xinit after recent update [Solved]

After I updated a couple days ago my laptop froze where I could see a virtual console login but couldn't type anything to login and couldn't change consoles with Ctl+Alt+F2 or F3, etc. and couldn't ssh into it. I had to hold the power button to power off and restart. I was able to boot into rescue m...
by twhite
Mon Jul 24, 2017 17:38
Forum: Sabayon Linux General Discussion
Topic: nodejs package installs unsupported npm version [Solved]
Replies: 3
Views: 727

Re: nodejs package installs unsupported npm version

I installed the 4.X npm from npm itself.

Code: Select all

npm install [email protected] -g
the 'X' in 4.X means the latest 4.x version.
It still loads npm 5.0.3 initally, didn't fix the packaging issue, but npm is working fine, no error messages, with the re-installed 4.X version.
by twhite
Fri Jul 21, 2017 16:06
Forum: Sabayon Linux General Discussion
Topic: nodejs package installs unsupported npm version [Solved]
Replies: 3
Views: 727

Re: nodejs package installs unsupported npm version

Spoke too early. As I continued, this doesn't really fix the problem. When I use other commands:

Code: Select all

create-react-native-app project-name
The issues is still there. Evidently that command uses npm.

I guess I'll have to figure out how to install the older 4.X npm.
by twhite
Fri Jul 21, 2017 15:37
Forum: Sabayon Linux General Discussion
Topic: nodejs package installs unsupported npm version [Solved]
Replies: 3
Views: 727

Re: nodejs package installs unsupported npm version

I resolved this by installing yarn, the second suggestion in the message.
Yarn is an alternative to npm.

Code: Select all

npm install yarn -g
Then I ran the create app. The command is slightly different.

Code: Select all

yarn global add create-react-native-app
Success!
by twhite
Fri Jul 21, 2017 1:47
Forum: Sabayon Linux General Discussion
Topic: nodejs package installs unsupported npm version [Solved]
Replies: 3
Views: 727

nodejs package installs unsupported npm version [Solved]

I'm trying to get npm working with nodejs 8.1.2~0. The npm version is 5.0.3 and when I try the following command: npm install -g create-react-native-app I get the following message: ERROR: npm 5 is not supported yet Create React Native App doesn't work with npm 5 yet, unfortunately. We recommend usi...