Search found 27 matches

by rdnetto
Fri Mar 25, 2016 10:33
Forum: Portage|Emerge Package Managers
Topic: Keeping Sabayon's Portage files up-to-date
Replies: 10
Views: 3694

Re: Keeping Sabayon's Portage files up-to-date

Sorry for the delay in replying, I've been pretty busy lately.

On new installs the script is not needed, as the git repo is used directly. I've updated the description to explain what to do instead.
by rdnetto
Sun May 31, 2015 14:51
Forum: Entropy|Equo|Rigo Package Managers
Topic: MPlayer and Smplayer - [Solved]
Replies: 4
Views: 1148

Re: MPlayer and Smplayer

Does anyone know why they removed packages "mpayer" and "smplayer" repository? They will come back? Mplayer and mplayer2 were old and unmaintained - they have been replaced by mpv. (Mplayer2 has been removed from Portage as well.) I have no idea why Smplayer has been removed - it works perfectly fi...
by rdnetto
Fri Apr 24, 2015 9:21
Forum: Entropy|Equo|Rigo Package Managers
Topic: Unable to upgrade packages [Solved]
Replies: 7
Views: 1765

Re: Unable to upgrade packages [Solved]

libav-9.17 is not masked in Entropy. :?: Are you sure that you did not mask it on your system? I did mask it on my system (because I installed libav-11.3 via portage). I know that using portage with entropy is not supported, but this bug can also manifest when using pure entropy. The reason I consi...
by rdnetto
Mon Apr 06, 2015 19:42
Forum: Entropy|Equo|Rigo Package Managers
Topic: Unable to upgrade packages [Solved]
Replies: 7
Views: 1765

Re: Unable to upgrade packages [Solved]

So, I did a bit of digging and it turns out there really is a bug in entropy. The exact conditions which trigger it are: mplayer (the package to be installed) has a dependency of the form 'ffmpeg OR libav'. [1] libav-9.17 (the version of libav in entropy) is masked the installed version of libav (11...
by rdnetto
Sun Apr 05, 2015 17:32
Forum: Entropy|Equo|Rigo Package Managers
Topic: Unable to upgrade packages [Solved]
Replies: 7
Views: 1765

Re: Unable to upgrade packages

joost wrote:You are the bug.

:alien:
Given the number of systems the apostrophe in my surname has broken, I'm sure you're not the only one who feels that way... :P
by rdnetto
Sun Apr 05, 2015 17:18
Forum: Entropy|Equo|Rigo Package Managers
Topic: Unable to upgrade packages [Solved]
Replies: 7
Views: 1765

Re: Unable to upgrade packages

EDIT: Ok, I've figured it out. Scroll to the bottom for answer. Nothing in Entropy deps on ffmpeg. Ran on server: eit q revdeps media-video/ffmpeg ☛ Not matched: media-video/ffmpeg I guess you used Portage on that system? Yes, though I didn't think Portage packages could block an upgrade like this, ...
by rdnetto
Sun Apr 05, 2015 13:44
Forum: Entropy|Equo|Rigo Package Managers
Topic: Unable to upgrade packages [Solved]
Replies: 7
Views: 1765

Unable to upgrade packages [Solved]

Hi, I am no longer able to install updates via entropy. $ sudo equo upgrade -p ╠ @@ Calculating System Updates: ╠ @@ 416 => Packages matching update ╠ @@ 36 => Packages matching not available ╠ @@ 1575 => Packages matching already up to date ╠ @@ Calculating dependencies... ☢ @@ Dependencies not fou...
by rdnetto
Wed Mar 18, 2015 16:10
Forum: Portage|Emerge Package Managers
Topic: libav upgrade
Replies: 3
Views: 1714

Re: libav upgrade

For the benefit of anyone else who runs into this problem, you can workaround it by emerging the master branch of Clementine (pending https://bugs.gentoo.org/show_bug.cgi?id=543692), and uninstalling gst-plugins-ffmpeg.
by rdnetto
Wed Mar 18, 2015 8:26
Forum: Portage|Emerge Package Managers
Topic: libav upgrade
Replies: 3
Views: 1714

Re: libav upgrade

Thanks, that was exactly what I needed to know. Looks like I'll just need to patch Clementine to use Gstreamer 1.0.