Search found 2552 matches

by joost
Wed Jul 01, 2020 19:20
Forum: Sabayon Linux General Discussion
Topic: Python 2 exorcism
Replies: 10
Views: 113

Re: Python 2 exorcism

This is going off-topic...
by joost
Tue Jun 30, 2020 17:47
Forum: Sabayon Linux General Discussion
Topic: Python 2 exorcism
Replies: 10
Views: 113

Re: Python 2 exorcism

It is a bit of a shitty situation right now. We are working Python 2.7 out of the tree, we are still on Python 3.6 and upstream Gentoo is already starting to drop support on Python 3.6 it seems. I had to fork some ebuilds to be able to get latest KDE Plasma https://github.com/Sabayon/for-gentoo/tree...
by joost
Tue Jun 30, 2020 16:43
Forum: Sabayon Linux General Discussion
Topic: Python 2 exorcism
Replies: 10
Views: 113

Re: Python 2 exorcism

Why not replacing that old build (removed) with the new package at the same time?
Because our tree is on Python 3.6
by joost
Fri Jun 19, 2020 19:52
Forum: Beginners|Newbies Area
Topic: How to upgrade few years old installation? Its redownloading lots of packages and after that fail..
Replies: 41
Views: 1589

Re: How to upgrade few years old installation? Its redownloading lots of packages and after that fail..

** Before you try this, backup your important work ** ** I only tested this on 1 system, maybe I was just lucky ** Ok this seems to work, though it is a bit ugly at first but it makes sense. This Portage version still has python 2.7 support and was created before libmigration. Download this file: h...
by joost
Fri Jun 19, 2020 19:27
Forum: Beginners|Newbies Area
Topic: How to upgrade few years old installation? Its redownloading lots of packages and after that fail..
Replies: 41
Views: 1589

Re: How to upgrade few years old installation? Its redownloading lots of packages and after that fail..

So the problem is, we need a portage package from just before the libmigration event and one that still supports Python 2.7. I now have the idea to boot an iso image from just before that time, generate an install-able portage package from that env. equo smart quickpkg portage would generate a tarba...
by joost
Wed Jun 17, 2020 13:43
Forum: Beginners|Newbies Area
Topic: Hi guys, how to install teamviewer using portage
Replies: 2
Views: 159

Re: Hi guys, how to install teamviewer using portage

Nope it is in repos. Maybe you had some older version that got removed? e.g. teamviewer 13? equo search teamviewer ╠ @@ Searching... ╠ @@ Package: net-misc/teamviewer-14.1.9025 branch: 5, [sabayonlinux.org] ╠ Available: version: 14.1.9025 ~ tag: NoTag ~ revision: 0 ╠ Installed: version: Not installe...
by joost
Mon Jun 15, 2020 21:29
Forum: Beginners|Newbies Area
Topic: Brand new install Gnome and /or KDE
Replies: 6
Views: 371

Re: Brand new install Gnome and /or KDE

At this point it is impossible to upgrade 19.03 to current. Use a daily image.

We are looking into creating a new "release" but we have some technical issues we need to overcome first.
If you use a daily build you should be fine though.
by joost
Fri Jun 05, 2020 21:38
Forum: Beginners|Newbies Area
Topic: How to upgrade few years old installation? Its redownloading lots of packages and after that fail..
Replies: 41
Views: 1589

Re: How to upgrade few years old installation? Its redownloading lots of packages and after that fail..

I have to conclude that since so many things changed past year, and we barely keep up with upstream Gentoo, it is now impossible to upgrade such an old system. unless you actually have a working compiler installed. Since by default Sabayon ships with split gcc where you only get libraries without th...